S-180-12 PSU Failiure

DQW
Posts: 33
Joined: Thu Dec 24, 2015 9:23 pm

Re: S-180-12 PSU Failiure

Post by DQW » Wed Dec 14, 2016 6:06 pm

First check if you have the L/N/G cables correctly connected,then check the 110V/220V switch on the PSU.
This I already did with first malfunctioning and second malfunctioning psu.
The next move is to unplug the board from the PSU and measure the AC input and DC output with a multimeter.
Do I measure the PSU or the Board? (How and where do I do that with my multimeter)(And does it have to be on or connected to the electric network?)

Thansku

Cup
Posts: 123
Joined: Fri Jul 15, 2016 6:11 pm

Re: S-180-12 PSU Failiure

Post by Cup » Thu Dec 15, 2016 12:01 pm

I mean the PSU(remember to unplug the board from it).
AC input is the voltage between "L" and "GND",check this post:
http://www.geeetech.com/forum/viewtopic ... 18&t=18061

walterfantauzzi
Posts: 6
Joined: Thu May 11, 2017 3:41 am

Re: S-180-12 PSU Failiure

Post by walterfantauzzi » Wed May 17, 2017 3:02 am

Hi Guys,

My PSU work only one day. Today it doesn't work. The Green Led is off!

I'm Italian and we have 220V I see inside the holes and I see the switch is correctly set in 220V.


So why it doesn't work??? I have read of many people who complain about this Power Supply Unit issues!


https://drive.google.com/open?id=0B5uIi ... Up4a3NvR1E

User avatar
William
Site Admin
Posts: 4642
Joined: Tue Jun 07, 2016 9:38 am

Re: S-180-12 PSU Failiure

Post by William » Wed May 17, 2017 1:38 pm

walterfantauzzi wrote:Hi Guys,

My PSU work only one day. Today it doesn't work. The Green Led is off!

I'm Italian and we have 220V I see inside the holes and I see the switch is correctly set in 220V.


So why it doesn't work??? I have read of many people who complain about this Power Supply Unit issues!


https://drive.google.com/open?id=0B5uIi ... Up4a3NvR1E
Maybe the PSU is dead.
Just replace it with a new one.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

walterfantauzzi
Posts: 6
Joined: Thu May 11, 2017 3:41 am

Re: S-180-12 PSU Failiure

Post by walterfantauzzi » Wed May 17, 2017 2:58 pm

William wrote:
walterfantauzzi wrote:Hi Guys,

My PSU work only one day. Today it doesn't work. The Green Led is off!

I'm Italian and we have 220V I see inside the holes and I see the switch is correctly set in 220V.


So why it doesn't work??? I have read of many people who complain about this Power Supply Unit issues!


https://drive.google.com/open?id=0B5uIi ... Up4a3NvR1E
Maybe the PSU is dead.
Just replace it with a new one.
Yes the technical support reply to me in PVT by email. The PSU is dead! So I would like to let you guys that me and a my engineer friend measured the current absorption with a current meter about the Prusa i3 MK8 and we've seen that it is higher than the 15A delivered by the PSU. The supplied PSU is underdimensional!

BrianR
Posts: 1
Joined: Tue Aug 15, 2017 4:19 pm

Re: S-180-12 PSU Failiure

Post by BrianR » Tue Aug 15, 2017 4:21 pm

Thanks for the clarification! Got it working.
I need a practice to prepare myself for a serious game. Still I don't need to worry if I fall short of free chips there. At columbusdeluxe777com everyone wins. Can you imagine that?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests