Printer not registering.

Post Reply
That Gamer 64
Posts: 2
Joined: Mon Jul 09, 2018 1:32 pm

Printer not registering.

Post by That Gamer 64 » Sat Nov 02, 2019 10:17 am

I just tried to turn on my printer and the lcd screen didn't light up. I thought this was weird, but the fans were running so it ha power. So I continued to see if my printer would connect to repeater host, and theres nothing. I then tried to see if my board would connect to Arduino. It didn't. Any body else hade this problem or did my g2s just die?

User avatar
Site Admin
Posts: 6339
Joined: Tue Jun 07, 2016 9:38 am

Re: Printer not registering.

Post by William » Mon Nov 04, 2019 9:24 am

Hi ,you can try to open the printer normally.
Measuring its output voltage,
Reconnect the screen cable,
Then check if there are three lights on the motherboard.
To make sure there is a problem with the motherboard.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Posts: 2
Joined: Tue Jan 05, 2021 5:31 pm

Re: Printer not registering.

Post by Alejandra » Tue Jan 05, 2021 5:34 pm

Internal memory reset.
Dirty or damaged contacts.
Protective strips.
Ink cartridge is not inserted correctly.
Incorrect consumable installed.
Cartridge Protection enabled. .


Posts: 1
Joined: Thu Apr 15, 2021 5:04 pm

Re: Printer not registering.

Post by ava121 » Thu Apr 15, 2021 5:07 pm

This article is really amazing. Thanks for the information, keep sharing this type of info.

getmyoffers capital one

Post Reply