A10M MARLIN 2.0 BLTOUCH NOT WORKING

Moderator: vert

Sack87
Posts: 2
Joined: Wed Oct 09, 2019 8:11 pm

A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by Sack87 » Fri Oct 11, 2019 5:54 am

Hi all,

Been printing for a while with 1.1.8 with no issues at all and just wanted to flash my Mega 2560 V3 board with the latest firmware for more features.
Took me a while to figure out how to get in done but there was no BLtouch enabled in the example config file.
I found this ----> https://github.com/iherbak/Geeetech-A10 ... guration.h and reflashed my printer but it's still not working.

What happens with either config file is that when I go to level the bed, it homes to X and Y but not Z (z stop is unplugged), then every time time i hit "next point", it homes X and Y then jumps up the Z axis about 5mm. It does this for all points just jumping up Z axis only everytime I hit next.
Autohome does the same thing and there is no BLtouch option on the LCD screen and it doesn't self test.

I have no idea about coding (i'm a mechanic!) so can't help much but if one of you could look at the config file, maybe you could fix it up. Since none of Vert's links or files are available anywhere, maybe someone who has his config files could share them on here.

Thanks, Brendon

User avatar
William
Site Admin
Posts: 5936
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by William » Fri Oct 11, 2019 9:14 am

Hi, If the latest firmware does not work,
I suggest you brush back the Marlin 1.1.8 version.
Make it work normally.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Sack87
Posts: 2
Joined: Wed Oct 09, 2019 8:11 pm

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by Sack87 » Fri Oct 11, 2019 9:25 am

Yes I have returned back to 1.1.8 but surely someone has the BL touch working on 2.0
There seems to be a lot of people who say they have it working with their own code but I don't understand the code and where to put it. Downloading a working config file is the best I can do :D

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

help A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Mon Feb 03, 2020 4:41 am

I have a Geeetech A10M 2560 V3 I use version 1.18 with the BLToch which works very well.
I made the Marlin V2.0 update which works perfectly except the Bltouch!
The G28 home command is not correct, the Z axis always goes up in 5mm steps without touching the Bed!
I have configured config.h but nothing to do I do not understand or is the problem?
I have the menu that displays the Bltouch setting with all the options ...
here is a copy
//#define PROBE_MANUALLY
//#define MANUAL_PROBE_START_Z 0.2
/**
* A Fix-Mounted Probe either doesn't deploy or needs manual deployment.
* (e.g., an inductive probe or a nozzle-based probe-switch.)
*/
//#define FIX_MOUNTED_PROBE
/**
* Z Servo Probe, such as an endstop switch on a rotating arm.
*/
//#define Z_PROBE_SERVO_NR 0 // Defaults to SERVO 0 connector.
//#define Z_SERVO_ANGLES { 70, 0 } // Z Servo Deploy and Stow angles
/**
* The BLTouch probe uses a Hall effect sensor and emulates a servo.
*/
#define BLTOUCH
Note: the Arduino file is well compiled as a hexa file
I unplugged the Bltouch to keep the Z axis adjustment at the end of point 0 travel.

Thank you for your help, I spent hours without finding anything.

sneazzy95
Posts: 8
Joined: Sat Dec 21, 2019 12:13 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by sneazzy95 » Mon Feb 03, 2020 5:46 am

I went back to the Marlin 1.1.8 version and it worked for me, thank you so much.

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Mon Feb 03, 2020 6:43 am

I do not understand the answer of green it seems that nobody knows how to solve the difficulty of Bltouch for version 2.0
official sources do not give the Bltouch solution.
I have an idea on the Zstop pine to change.
anyway, the Marlin 2.0 version works fine without the Bltouch.
I integrated the statistics the filament counter and the duration of the prints and the longest time, the total length of the filament consumed.
to reread you
do we have a good technician to repair the Bltouch? in the Marlin 2.0 firmware
a+ francis

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Mon Feb 03, 2020 3:02 pm

Hello,

Thank you Green but the link does not give the source of the modification of the configuration.H file!
What I am asking is not how to connect a BLtouch but how to modify the file.
write #define bltouch ;)
// # define Z_PROBE_SERVO_NR 0
// # define Z_SERVO_ANGLES {70, 0}
for the rest I do not know why the Bltouch does not make the G28 home?
please give us the config.h file
thank you for your collaboration :D
a+

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Mon Feb 03, 2020 9:57 pm

Thank you for offering me your link on GitHub! :shock:
I have a lot of reading and I don't know what to look at anymore.
which line should I change for Bltouch?
I registered on your web page on the forom
cordially

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Tue Feb 04, 2020 12:16 am

thank you it is good to refer to a computer link or a video on youtube alas I have covered everything and all this does not correspond to my need.
I have the impression that the subject is a mystery because you do not have the solution or quite simply you do not bring any analysis or solution to the whole of the forum. Many people count on your competence support and an answer I am an engineer and I am not a beginner.
Sorry but I wonder what can this forum be for?
I watched the video it's a nice demonstration without more ...
Sorry to say what I think ... I realize technical tutorials that explain everything about electronics.
in detail I take time and also explain to beginners.

vap38
Posts: 23
Joined: Wed Sep 04, 2019 3:41 am

Re: A10M MARLIN 2.0 BLTOUCH NOT WORKING

Post by vap38 » Tue Feb 04, 2020 3:28 am

I want to help everyone who has the problem, I need your knowledge!
The A10M printer works very well with the Bltouch with MARLIN 1.18, it's perfect

when I compile Marlin v2.0 with ARDUINO 1.1810, it asks me to block the following lines:
1 // # define Z_PROBE_SERVO_NR 0
2 // # define Z_SERVO_ANGLES {70, 0}
then I write 3 #define bltouch to validate the function.
Compiling at the end works fine without error.
BLtouch does not know the G28 home Z axis, it goes up in 5mm steps with each order.
this function is not normal.
I saw that the Z limit switch detection for the Bltouch is pin 60 Z mini Carte-2560 on the card.
you may have to declare this pin which by default offers pin 32 on the ground!
The question can tell us what you have for lines 1 - 2 - 3. in the Marlin Config.h file. :?:

Which version of the ARDUINO app do you have :?:
The latest version of ARDUINO has a virus .... :oops:
I want to collaborate and share my knowledge.
Here is a link for which I helped users in France who have broken down for the Geeetech a10 firmware
https://www.lesimprimantes3d.fr/forum/t ... ne-gt2560/
I have the will with you to find the problem.
we will help everyone out :lol:

Locked

Who is online

Users browsing this forum: No registered users and 3 guests