How do I upload Marlin to a GT2560?

Post Reply
Posts: 1
Joined: Tue Jul 09, 2019 3:39 pm

How do I upload Marlin to a GT2560?

Post by Ariovist » Sun Jul 14, 2019 9:25 am

I bought a Geeetech GT 2560 Rev A+ for my i3 Pro B - Printer. I connected it correctly to the printer, turned it on, and just saw a blue screen with 2 white bars on it. So I assumed that the board didn´t have any firmware on it (can´t check that on the seller´s page bcause I forgot where I bought it). So I tried to upload the firmware like it said in the Geeetech Wiki (, but nothing worked. I already had the red stepper drivers mounted onto it (A4899), and the only thing the board did was blinking (a yellow LED). So I tried uploading different versions of Marlin with different Versions of the Arduino IDE (1.0.1, 1.0.6, 1.8.6, 1.8.9, etc.). I changed the upload-speed in the boards.txt-file to 57600... Do I have to burn a bootloader onto the 2560 with another Arduino? What can I do now? Thx for your help!

User avatar
Site Admin
Posts: 6339
Joined: Tue Jun 07, 2016 9:38 am

Re: How do I upload Marlin to a GT2560?

Post by William » Mon Jul 15, 2019 9:40 am

Hi, do the three lights illuminate when the printer is normally turned on on your motherboard? Can you provide a specific picture of your motherboard? To better understand your problem.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Posts: 1
Joined: Wed Jun 30, 2021 4:09 pm

Re: How do I upload Marlin to a GT2560?

Post by Bayer00 » Fri Jul 16, 2021 3:47 pm

Off course, uploading Marlin to a GT2560? wasn't very easy for you but you didn't give up and kept on struggling until you got succeed. I have just written and uk dissertations got motivation from your activity to upload it successfully so it will be very good for me to be a courageous person like you.

Post Reply