Geeetech A10M, bad printing since purchase

Moderator: vert

Post Reply
Pajarobergaz
Posts: 2
Joined: Sat Aug 24, 2019 5:42 am

Geeetech A10M, bad printing since purchase

Post by Pajarobergaz » Sat Aug 24, 2019 6:12 am

A few months back I bought a geeetech a10m from internet. The package was good and the pieces arrived in good shape.
After screwing and assemble the printer I made some tests. Of course the quality of the pieces wasn´t very good so I dedicated a lot of updating the firmware, adjust the screws of the extruder, perfectly level the bed, cleaning the axis, adjusting the steps on the memory (since the original number is wrong from factory) and made a deep cleaning.

Nothing has changed in the quality, there are layer shifts, a lot of stringing, under extrusion even with a ridiculous amount of flow. I tried changing the filament brands, a lot of parameters and slicers but I can get a good quality print.

Hope someone can help me.

User avatar
William
Site Admin
Posts: 4172
Joined: Tue Jun 07, 2016 9:38 am

Re: Geeetech A10M, bad printing since purchase

Post by William » Mon Aug 26, 2019 9:32 am

Hi, Can you provide a quality picture of the model you printed or a video when you printed it?
So that we can solve the problem better.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

plumix
Posts: 1
Joined: Fri Nov 23, 2018 3:40 pm

Re: Geeetech A10M, bad printing since purchase

Post by plumix » Mon Sep 02, 2019 12:19 pm

i HAVE THE SAME PROBLEMS SINCE JANUARY WITH MY A10 !

Pajarobergaz
Posts: 2
Joined: Sat Aug 24, 2019 5:42 am

Re: Geeetech A10M, bad printing since purchase

Post by Pajarobergaz » Tue Sep 03, 2019 1:22 pm

I would like to post a picture, but I don´t have the patience to know how to use the Image for this forum.

I gave a last chance to the printer following this post: https://www.geeetech.com/forum/viewtopi ... 6&start=10. However, the screws wont get out (tried to remove them 3 whole days) and it looks like the nozzle is perma-clogged.

The part I hate the most is "it is true they are intended as anti back flow but it is also true these disks are the direct cause of 100s of other issues and when there removed there are zero noted draw backs.
they need to stop putting these disks in at the factory they are self sabotaging there own products with them.
many of my discord users have done this and all of there issues went away and had no issues since its been many months since they did this." - Vert.

It clearly looks like Geeetech doesn´t know how to make quality products. At least, my printer didn´t work properly after 6 months working on it. The structure its ok (maybe) but the extruder is trash.

I feel I wasted my money with this printer.

Jarda3d
Posts: 47
Joined: Sat Jan 26, 2019 8:42 am

Re: Geeetech A10M, bad printing since purchase

Post by Jarda3d » Thu Sep 05, 2019 6:46 am

Try to use my printing profile

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests