A10 3D Touch sensor consistently too low on the left and too high on the right of the bed

Moderator: vert

Post Reply
musicteckey
Posts: 1
Joined: Sat May 21, 2022 11:32 am

A10 3D Touch sensor consistently too low on the left and too high on the right of the bed

Post by musicteckey » Sat May 21, 2022 11:35 am

I recently purchased an A10 and quickly upgraded it with the super plate glass bed and a 3D Touch sensor.

I have installed the sensor and set the offset correctly and installed the latest (1.1.8) 3D Touch firmware for my V3 board from Geetech's website.

However, after running the 'bed leveling' function, I ran the 'level corners' function to see the result and found that the nozzle was far too close to the bed on the left side (front and back) and too far away from the bed on the right (front and back). Unsurprisingly this causes serious print quality issues. This is a consistent fault, although I have noticed while monitoring the serial output that the offset values produced by the bed leveling function are different every time, although they are always positive values for the left sides and negative values on the right. The sensor is tightly secured to the extruder and does not seem to be loose.

Looking through this forum, it seems that a few other people had this exact same issue, but those posts are from a few years ago and I cannot find a resolution to the problem.

Has anybody got the 3D Touch sensor to work on their A10, and if so, what is the fix?

Many thanks.

Post Reply