I3 Pro W calibration and PLA adhesion issues

Post Reply
Thoth
Posts: 5
Joined: Mon Feb 24, 2020 11:45 am

I3 Pro W calibration and PLA adhesion issues

Post by Thoth » Mon Feb 24, 2020 12:13 pm

Greetings,

My eldest received this I3 Pro W a couple of years ago. They were only ever able to get one print, and that was not very solid or very good.
The youngest is now finding the odd bit of requirement for a 3d Printer, and a few friends have some items they want to print, so I thought I'd give it a go.

I've installed EasyPrint3D v 1.2.6. I've upgraded the I3 Pro W to firmware v.1.0.05.
Communication is possible, and the unit will respond to the control module.

Attempting to print a test pattern from Thingverse, a fairly low profile peace sign resulted in PLA spaghetti at the best of times.

I've looked at nozzle temps of 200 to 215 degrees C - I've walked up and down that range. I've set the bed at 55, 60, 65, 67, 70, 75, and 80 degrees. No go.

My eldest has put one of those full sheet 3d stickers (probably Kapon) on the glass plate. The PLA will not adhere consistently. At best it deposits bits and blobs and you get a stretch string between these. All print attempts end up balled up around the print head.

I've calibrated the head to bed distance using the documentation, which states to use a piece of A4 paper folded in half, and look for a bit of drag between nozzle and bed. Check. The website shows a video of this, but, using single width. Neither resulted in adhesion.
I've discovered that the wooden base plate for the bed has a very observable curl that makes the whole leveling process a mighty challenge - I believe I've got the system as tuned as well as I can on the gap between the bed and the nozzle given this challenge.

I've noticed that the firmware has a value of 2.5 for the filament diameter, and this can be increased, but not decreased. The PLA that came with the unit, and other product we've purchased is 1.75. The EasyPrint3D software accommodates this, but I have a suspicion this isn't getting through.

The PLA flow rate at default is 120% - this results in very little filament coming out. I've bumped that up to to 180% with only a small improvement, still not an acceptable print.

I've switched from skirt to Brim, with no improvement.

I've disassembled and checked the extruder stepper motor to see if it is indeed advancing the material, and I can see it move at 1 mm, it does nothing with 10 mm. I've cleared the nozzle as best I can.

The only time I can get what appears to be a reasonable filament size is if I add a bit of encouragement manually by pushing the PLA into the extrusion control area - I can't do that for an entire print.

I've seen lots of similar issues by others on this forum, and as people work through the problem, suddenly there's a message that it's all fixed, but there's no clear indication of what has worked. Mildly frustrating when you're reading to try to find answers :-)

I normally work with logs to debug stuff, but if EasyPrint3D is generating logs, I'm not aware of any. Oh, for the record, this particular unit is not using the T8 rod, but the finer threaded rod. I've sent the Gcode to set it accordingly.

Any brilliant ideas folks?

Thoth
Posts: 5
Joined: Mon Feb 24, 2020 11:45 am

Re: I3 Pro W calibration and PLA adhesion issues

Post by Thoth » Tue Feb 25, 2020 10:07 am

Not that your post's time stamp is an indication, but I suspect a live session is going to be a challenge. :-)

I posted late, after several days of effort, before hitting the hay. (I sacrificed a couple of hours of sleep that is much needed for work as part of this effort - silly me :-) )

Otherwise I'm game, but getting setup for video may be a bit tricky, and need me to wait until the weekend.

Thoth
Posts: 5
Joined: Mon Feb 24, 2020 11:45 am

Re: I3 Pro W calibration and PLA adhesion issues

Post by Thoth » Wed Feb 26, 2020 10:53 am

So,

Had a few minutes tonight, made a leather shim for the warped corner.
20200225_212342.jpg
20200225_212342.jpg (252.73 KiB) Viewed 2605 times
Re-leveled the bed, used a single thickness of A4 paper this time.
Ran a job at 100% size with bed temp at 75 deg. C, nozzel temp at 215 deg. C.
Switched the firmware via the control panel to use mm feed - it was off...
Rate is slow - 10 mm/s on average.

Still using Easyprint3D.

Got this mess, but, this is more than I've gotten in the past.
20200225_202654.jpg
20200225_202654.jpg (418.76 KiB) Viewed 2605 times
20200225_202718.jpg
20200225_202718.jpg (204.84 KiB) Viewed 2605 times
Ran second job, upped bed temp to 80 deg. C., first layer at 210 deg. C. Second layer at 205 deg. C.

This is the result on the brim:
20200225_212335.jpg
20200225_212335.jpg (222.4 KiB) Viewed 2605 times
Trying another with only the bed temp dropped to 65 deg. C. and will have to head to bed soonish....and it was a bust. No picture, far less PLA deposited.

Thoth
Posts: 5
Joined: Mon Feb 24, 2020 11:45 am

Re: I3 Pro W calibration and PLA adhesion issues

Post by Thoth » Sun Jul 05, 2020 11:31 am

So, I started this thread some time back, life happened, then the original equipment MK8 extruder with the plastic parts utterly died - the stepper motor just flat out stopped working. So to help others out, because there are a lot of threads that start, and then someone simply says "It's working now!" or worse, say nothing at all, I thought I'd put out what I discovered in the past couple of weeks.

I ordered a new one, and waited for it to arrive, it took a bit longer thanks to Covid-19, but arrive it did. However, there were still other priorities to deal with. Things started to calm down a bit, and I did a bit more research on the net, because, even with the new aluminum based MK8 extruder, I was getting a mess.

My research lead me to feel that even with FW v1.0.05, something had mis set the Extruder step value incorrectly. 1.8 degrees means a full rotation is 200 steps. So I started playing, using the step value calculators and eventually settled on a new number to feed via M92 EXXX when I was trying to calibrate the Extruder. I think I settled on 523.96... and that's using 1.75 mm filament. I also found that the firmware was using 2.5 mm as the filament diameter. I couldn't set that via the dial on the unit, but I pushed it through via Gcode. So, now, when given the reasonable string G1 E100 F40, my extruder runs nearly 100 mm through the hot end and doesn't get backed up.

Cool.

I started by slowing the test prints down to 5 mm/s for every action across the board. I then started tinkering with the feed rate until I started getting nice solid PLA lines being laid down. I started at 15, tried 20 mm/s, jumped to 45 mm/s on a hunch. This is when I actually got PLA to stick to the plate. It was definitely squished, but it stuck!

That brings me back to the default.ini file for EasyPrint3D. That file uses a feed rate that's just out of this world insane: feedrateMaxE=299792458000, I've reset that to 45 mm/s, which seems to push a bit too much, and I know 40's not bad as well but still seems to push a bit too much pla. 35 seems to be a bit light - my top layer calibration cube had holes. So, I'm trying at 38 mm/s for a different test right now, and will re-run the calibration cube in the morning.

I'd like to know where that enormous feed rate came from? I'd say based on the MK8, it's bloody hard to push more than 45 mm/s of 1.75 mm filament through a .4 mm nozzle, and I imagine if I ever try 3 mm filament, I'll be backing that number off a fair bit.

I know others have suggested using other tools, and I've tried, but so far, EasyPrint3D v. 1.2.6 actually extrudes filament. Repetier-Host will generate Gcode, but oddly, doesn't seem to be stick the extrusion code on each line of Gcode (Yes, I've dug that deep, Gcode is very similar to assembly language to me - yes, I'm that many years old :D - at any rate, that's a problem for another day...

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests