I3 ProC Dual Extruder does not start up

Post Reply
cepping
Posts: 3
Joined: Thu Sep 19, 2019 5:15 am

I3 ProC Dual Extruder does not start up

Post by cepping » Thu Sep 19, 2019 5:26 am

Hey,
I bought a i3 pro c dual extruder a few months ago and finally had the time to build it and start setting it up .
I can connect the printer via usb to my computer and was able to both connect it to repetier host and to install the firmware ( marlin 1.1.8), however when i connect it, the printer doesn't seem to start anything. I can not move the extruder in any direction ( the stepper motors are not turning on) and i can't heat the bed or extruder. It is plugged in and i am pretty sure i assembled everything correctly. There is a green led on on the board and the lcd screen turns on as well. When i try to heat one of the extruder it shows up on the lcd screen, that the extruder is starting to heat up, but before actually heatng up it says that it failed ( Error: Heating failed, system stopped! Heater_ID: 0

I am not quite sure what i am doing wrong.
If anyone could help me it would be greatly appreciated.

Carl

User avatar
William
Site Admin
Posts: 5922
Joined: Tue Jun 07, 2016 9:38 am

Re: I3 ProC Dual Extruder does not start up

Post by William » Thu Sep 19, 2019 9:23 am

:D Hi,for PRO C firmware, if you are using Arduino for updates, please use Arduino1.0.1 and then refer to this link for updates: http://www.geeetech.com/forum/viewtopic ... 20&t=17046

Regarding the heating problem of the extruder, you can check if your extruder thermistor is fully inserted.
If it is fully inserted, measure the resistance of the thermistor.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

cepping
Posts: 3
Joined: Thu Sep 19, 2019 5:15 am

Re: I3 ProC Dual Extruder does not start up

Post by cepping » Sat Sep 21, 2019 5:22 am

Hey,
thanks for your answer!
I tried updating the firmware with arduino 1.0.1, but it said it couldn't do it, and that it needed at least 1.6.5. So i tried it with 1.6.5 and that seemed to work, but after rebooting it, the light of the lcd came on but the text didn't show up. Also, instead of only the green light coming on on the gt2560 board, there is now also a orange light flashing.
Carl

cepping
Posts: 3
Joined: Thu Sep 19, 2019 5:15 am

Re: I3 ProC Dual Extruder does not start up

Post by cepping » Sat Sep 21, 2019 5:32 am

UPDATE
So the text showed up for a few minutes, when i tried to move the extruder in any direction, it wouldn't initialize the stepper motors. After a few minutes the text disappeared again and i am back where it only lights up the lcd. ( the green light and the yellow light on the board are still on)

User avatar
William
Site Admin
Posts: 5922
Joined: Tue Jun 07, 2016 9:38 am

Re: I3 ProC Dual Extruder does not start up

Post by William » Mon Sep 23, 2019 9:10 am

Hi, Are you referring to the white screen on the printer screen after refreshing the firmware?
Can you use CURA,
if you can, you can go to the official website to download the compiled HEX format file.
:https://www.geeetech.com/download.html?download_id=35

Then select in the Settings-printer-manger printer
0.2.png
0.2.png (97.32 KiB) Viewed 2528 times

Select update fw
0.3.png
0.3.png (93.1 KiB) Viewed 2528 times
If there is still a problem, can you provide a specific video?
So that we can solve the problem better.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests