A30m bug, shift layers

Post Reply
Posts: 17
Joined: Tue Jan 21, 2020 2:27 pm

A30m bug, shift layers

Post by Ahrovan » Thu Feb 27, 2020 2:44 pm

Our 3dprinter has a problem. I can not fix this problem
Shift layers like this

We checked this items:
- change model
- change software
- change speed to 50 -> 35mm/s, and change travel speed to 40mm/s
- check y axis belts
- level 3d printer bed

Problem not solved

User avatar
Site Admin
Posts: 6186
Joined: Tue Jun 07, 2016 9:38 am

Re: A30m bug, shift layers

Post by William » Fri Feb 28, 2020 11:19 am

Hi,you can check the voltage of your driver board, the tightness of your x-axis belt.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Posts: 8
Joined: Sat May 13, 2017 6:17 pm

Re: A30m bug, shift layers

Post by slipknot28 » Sun Mar 01, 2020 3:15 am

Do you use Cura software for slicing?

I also had this problems when I used Cura slicer.
With any other slicer printer is working without problems.
Now I am using IdeaMaker.

Posts: 17
Joined: Tue Jan 21, 2020 2:27 pm

Re: A30m bug, shift layers

Post by Ahrovan » Mon Mar 02, 2020 5:45 am


Posts: 5
Joined: Thu Dec 12, 2019 5:56 am

Re: A30m bug, shift layers

Post by Vilab » Tue Mar 03, 2020 12:01 am


GEEETech A10, Marlin 1.1.8

I had a similar issue slicing with CURA with "Z-hop" enabled ( a 3D benchy suffered 15+ layers shift )

unenabling it removed the issue

also, it looks like you under extrude a bit

Posts: 17
Joined: Tue Jan 21, 2020 2:27 pm

Re: A30m bug, shift layers

Post by Ahrovan » Mon Mar 09, 2020 7:11 pm

please describe more :idea:

Posts: 66
Joined: Tue Feb 11, 2020 9:45 am

Re: A30m bug, shift layers

Post by Sodium100mg » Wed Mar 11, 2020 2:44 am

Have you tried upgrading firmware? There is no bigger waste of time than trying to fix a problem that has already been fixed.

I'd test the Z screw. Things move simultaneous, so a binding on the Z could be reflected in the X. Unlock the motors and turn the Z up and down. Then use the jog to run the screw all the way up and down, listen for any noises. Clean it. Look at the bearings on the far side and tighten the whole structure. check the bearings are tight.

Swap motors around and see if the problem shifts axis.

On the side of the lower portion of the box, look for a dent when the nozzle impacted the side of the box causing the missed steps. Or is there any bit of filament floating around in the belts that is causing the problem. With how good everything else looks, it shouldn't be a loose belt. You said you re-leveled the bed, also make sure it is tight and you have good adhesion between the bed and the print.

I can't imagine a gcode error that could cause it, other than the z-hop issue others have mentioned that newer firmware might help. I'm guessing the z-hop on landing can pound in like a tent stake and cause side motion issues, when combined with other variables.

Setup your camera to take a video and watch what happened. Set the frame rate low.

I don't want to sound like an octoprint salesman (octoprint is free), but it sure is nice to have a log file (and timelaps) to look back on and see what happened, rather than guess. If the problem is a motor error, there will be nothing logged.

The speed you are running seems slow, not that it should be a problem, just that you are not pushing the motor limits. I'm running at 100m/s and would not be surprised if I saw crazy stuff.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests