Generic Silver PLA Filament not Sticking to Plate

Post Reply
OldWizard
Posts: 4
Joined: Wed Sep 23, 2020 6:01 pm

Generic Silver PLA Filament not Sticking to Plate

Post by OldWizard » Thu Oct 08, 2020 8:39 pm

Hi all,
I have a Geeetech A20 and get good results using Geeetech PLA. This sticks to the Black stick on surface supplied without glue of any sort.

However, when I tried a print with a Generic Silver PLA, it refused to stick! I tried PVA, Pritt stick, and hairspray. I also tried various temperature settings for both the plate and head. In desperation I tried again with glue and printed a raft, which took ages and used a lot of plastic.
I thought I had cracked it until after 5+ hours of printing, the raft started curling up at the corners and eventually the whole print detached.

Then I had a brainwave, {I don't get many at my age of 77!}. I started my print again,using a Brim with Black Geeetech PLA. This fixed firmly to the bed, and I kept the print running till it got to 1.5mm high. I then paused the printer, and changed the filament to the generic silver PLA, and then restarted the printer. This idea worked like magic. The small amount of Black on the underside of the print is not important.

Therefore, if you have similar problems, try an UNDERCOAT.
Happy printing!

User avatar
William
Site Admin
Posts: 6338
Joined: Tue Jun 07, 2016 9:38 am

Re: Generic Silver PLA Filament not Sticking to Plate

Post by William » Sat Oct 10, 2020 11:40 am

Thank you for sharing. :D
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

apollos
Posts: 3
Joined: Tue Oct 20, 2020 5:43 pm

Re: Generic Silver PLA Filament not Sticking to Plate

Post by apollos » Tue Oct 20, 2020 5:50 pm

Hi, thanks for sharing it's really good to know.

Appvalley TutuApp Tweakbox

Post Reply