3d touch sensor g-code and endstop issues

User avatar
William
Site Admin
Posts: 4614
Joined: Tue Jun 07, 2016 9:38 am

Re: 3d touch sensor g-code and endstop issues

Post by William » Fri Apr 28, 2017 9:34 am

lucapon wrote:Hi, I tried inverting black and white pins but it doesn't work.. How can I do?
Hi,could you take a video about your issue?
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

lucapon
Posts: 10
Joined: Thu Apr 20, 2017 11:44 pm

Re: 3d touch sensor g-code and endstop issues

Post by lucapon » Fri Apr 28, 2017 6:34 pm

Sure, here's the link to a dropbox folder with videos: https://www.dropbox.com/sh/peqc4hbt923m ... 1u18a?dl=0
The first video is for wireing and power on and the second is for auto calibration

User avatar
William
Site Admin
Posts: 4614
Joined: Tue Jun 07, 2016 9:38 am

Re: 3d touch sensor g-code and endstop issues

Post by William » Tue May 02, 2017 4:26 pm

Hi,have you tried the following g.code that can be used manually to diagnose
faults?If the 3dtouch act what it should be,the 3dtouch is normal.please adjust the screw on top of the sensor.
M280 P0 S10 ; pushes the pin down
M280 P0 S90 ; pulls the pin up
M280 P0 S120 ; Self test – keeps going until you do pin up/down or release alarm
M280 P0 S160 ; Release alarm
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

lucapon
Posts: 10
Joined: Thu Apr 20, 2017 11:44 pm

Re: 3d touch sensor g-code and endstop issues

Post by lucapon » Tue May 02, 2017 6:07 pm

I have tried that commands yet but nothing happened.

lucapon
Posts: 10
Joined: Thu Apr 20, 2017 11:44 pm

Re: 3d touch sensor g-code and endstop issues

Post by lucapon » Wed May 03, 2017 5:38 pm

What can I do? Is a sensor fault?

oaky69
Posts: 2
Joined: Fri Apr 21, 2017 10:47 pm

Re: 3d touch sensor g-code and endstop issues

Post by oaky69 » Fri May 05, 2017 1:39 am

Just installed mine and it is doing the exact same thing.
Pin goes up and down when you switch printer on but nothing else works
m280 p0 s10 and m280 p0 s90 does nothing.


Can anyone help ?

User avatar
William
Site Admin
Posts: 4614
Joined: Tue Jun 07, 2016 9:38 am

Re: 3d touch sensor g-code and endstop issues

Post by William » Sat May 06, 2017 11:17 am

Hi,I think you still need to adjust the sensor to the critical point at first.Follow this video:
https://www.youtube.com/watch?v=Ix7lXvf ... e=youtu.be.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

lucapon
Posts: 10
Joined: Thu Apr 20, 2017 11:44 pm

Re: 3d touch sensor g-code and endstop issues

Post by lucapon » Sat May 06, 2017 4:52 pm

You wrote it yet but I'm not in allarm mode and my sensor is yet to the critical point

zwollerob
Posts: 3
Joined: Sun May 07, 2017 8:39 pm

Re: 3d touch sensor g-code and endstop issues

Post by zwollerob » Sun May 07, 2017 8:46 pm

I have the same problem with my 3d touch! :(

Tried every thing but the thing does not respond to the M280 command.
Tried the screw and changing cables.

When turning on the probe is going out-in-out-in and the light is red.
When sending M119 the end stops are all open
After inverting the Endstop in the firmware the Z-min is triggered.

When manual deploy the probe it is still triggered.

Now reading here there are a lots of people here with the same problem.

Also the M280 commands are NOT working..

Code: Select all

> 14:27:36: N17 M280 P0 S10 *13
> 14:27:41: N22 M280 P0 S120 *57
> 14:27:48: N30 M119 *57
< 14:27:48: Reporting endstop status
< 14:27:48: x_min: open
< 14:27:48: y_min: open
< 14:27:48: z_min: TRIGGERED
> 14:29:01: N99 G28 X0.00 Y0.00 Z0.00 *102
< 14:29:03: echo:Z probe out. bed
When i want to home the Z the LCD is displaying Z Probe out. bed

Tought I bought a easy to install product. But it is already taking me 2 days with NO LUCK. :(

When returning to the default firmware without 3d-touch it works fine. but I hate leveling my bed every time I use the printer...

Hopefully anyone has found a solution

Are there other pins to test?

zwollerob
Posts: 3
Joined: Sun May 07, 2017 8:39 pm

Re: 3d touch sensor g-code and endstop issues

Post by zwollerob » Sun May 07, 2017 10:27 pm

fixed it.... Just solder the signal (orange cable) to the R22

And now it works like a charm!

Now calibrating time!!! :mrgreen:
Attachments
Foto 07-05-17 16 24 36.jpg
R22
Foto 07-05-17 16 24 36.jpg (235.07 KiB) Viewed 7620 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest