X Axis always triggered

Post Reply
Jon313boy
Posts: 2
Joined: Fri Apr 21, 2017 4:05 am

X Axis always triggered

Post by Jon313boy » Fri Apr 21, 2017 4:34 am

My prusa pi3 pro c dual extruder will not home x axis. When I run the M119 code all endstops works except the x axis. It stays triggered no matter if its unplugged. All other triggers work, i tried to invert endstop code from false to true, which makes x trigger open but when pressed it still reads the same.

I changed switch with others and new one, including wire.
I've check board for cross solder point and there all good.
I have another printer that is the exactly the same and swapped board but the same issues.

When I home x axis, extruder moves a nudge to the left but stops. The other axis home just fine. I believe the x axis stops after the nudge because the endstop is always triggered, falsely thinking its home.

I've yet to run plastic thru the extruder, but when I try to print, everything seem fine except it prints to far left.

Any ideas on how to solve this?

User avatar
William
Site Admin
Posts: 4500
Joined: Tue Jun 07, 2016 9:38 am

Re: X Axis always triggered

Post by William » Sat Apr 22, 2017 11:55 am

Hi,could you take some videos about it?It will be better to understand and get it solved.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Jon313boy
Posts: 2
Joined: Fri Apr 21, 2017 4:05 am

Re: X Axis always triggered

Post by Jon313boy » Tue May 16, 2017 5:48 am

The x axis and the extruder were operating in the wrong direction, so i turned the nema connector around to reverse polarity. I did the same to the extruder motor. When i try to hoe the x axis it move just a little to the left but it never homes or hits the endstop.

Post Reply

Who is online

Users browsing this forum: No registered users and 15 guests