Power Supply Problem - Geeetech I3

Post Reply
PedroT
Posts: 5
Joined: Thu Dec 15, 2016 4:38 pm

Power Supply Problem - Geeetech I3

Post by PedroT » Thu Dec 15, 2016 4:41 pm

I set up the printer by following the steps in the manual and the indicated videos, but a problem has occurred and now it is not working. Before turning on I checked the correct voltage and changed the internal switch of the power supply as indicated (For 220V - Switzerland).
The printer worked the first few times I turned it on but the third or fourth time, it made a small noise in the power supply and after the internal light of the power supply blinked a few times, it went off. And now it doesn't turn it on anymore, just the power button that lights up.
I think the power supply came with some flaw.

I could not verify if the other components are working properly because of this failure.

I would like to know how to proceed (if it is possible to fix), if not I expect to receive another power supply.

Cup
Posts: 123
Joined: Fri Jul 15, 2016 6:11 pm

Re: Power Supply Problem - Geeetech I3

Post by Cup » Fri Dec 16, 2016 11:12 am

You are right,you can't check other parts if the PSU was broken...
You can measure the AC input and DC output on the PSU to have a look,then i guess the green light on PSU is not on as my picture shows?
power led.jpg
power led.jpg (75.59 KiB) Viewed 4477 times

PedroT
Posts: 5
Joined: Thu Dec 15, 2016 4:38 pm

Re: Power Supply Problem - Geeetech I3

Post by PedroT » Tue Dec 20, 2016 11:24 pm

No, my green ligh start to blink as soon as I turn it on and then goes off. And the LCD does the same, sincronized. I stop trying to turn it on because i'm afraid to damage other components.
I don't have a multimeter to mesure the AC input and DC output.

Image

Cup
Posts: 123
Joined: Fri Jul 15, 2016 6:11 pm

Re: Power Supply Problem - Geeetech I3

Post by Cup » Wed Dec 21, 2016 4:28 pm

So you can unplug the board from the PSU first,then turn on the power.Attach a picture of its opening state.

PedroT
Posts: 5
Joined: Thu Dec 15, 2016 4:38 pm

Re: Power Supply Problem - Geeetech I3

Post by PedroT » Wed Dec 21, 2016 8:24 pm

I unpluged the board from the PSU and turned it on. See the photo.
I made a video to: https://youtu.be/b04PFlWenQ8

Image

Cup
Posts: 123
Joined: Fri Jul 15, 2016 6:11 pm

Re: Power Supply Problem - Geeetech I3

Post by Cup » Thu Dec 22, 2016 4:38 pm

Looks like the PSU was broken...
Maybe you can contact the seller to talk about it.

PedroT
Posts: 5
Joined: Thu Dec 15, 2016 4:38 pm

Re: Power Supply Problem - Geeetech I3

Post by PedroT » Sun Jan 08, 2017 3:55 am

I have received another source from the seller and it is apparently functioning properly. Thanks for the help!

Cup
Posts: 123
Joined: Fri Jul 15, 2016 6:11 pm

Re: Power Supply Problem - Geeetech I3

Post by Cup » Wed Jan 11, 2017 11:59 am

Glad to hear that. :D

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests