Absolutely desperate

Post Reply
otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Absolutely desperate

Post by otibook » Mon Aug 24, 2015 12:16 am

I have bought a G2s at eBay(eBay user:easybuy) on June 2015. Since I bought it I have build 2 Prusa I3 for a pair of friends without any problem(they are printing spiders and carriages for my printer). So, now I´ve some experience building to build G2s. The G2s arrives about july 20th it comes with 1 carriage and spider broken. I had to wait 2 weeks more to start building of my printer. Once finished i have trying to calibrate and start for 2 weeks. It´s absolutely imposible. I have download and modified firmware(wiki link) as indicated in the wiki and revised 3 or 4 times. Now i have the following problems.

1- G29 command: after the probe touch the platform 16 times XYZ motors start to growl as belt skipping teeth.
2- Sending to home I have the same growls when the carriages are near the stop switch.
3- extruders motors are reversed. when I click extrude button on repetier the filament retracts. If I click retract then filament goes forward. I have checked the connections several times. In the board and in the motors there is no choice connecting, the plastic connector only fit in one position. So I don't have any idea what´s going on the extruders.Could it be firmware settings?
4- I have broke 2 spiders more trying to calibrate.

Please help me.

I am absolutely desperate, and feeling I have waste my money.

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Absolutely desperate

Post by Mark » Mon Aug 24, 2015 2:42 pm

1) " Sending to home I have the same growls when the carriages are near the stop switch"
Does the threaded rod assembled correctly? Does it bended or not?

2) "extruders motors are reversed"
As for this, you can change the direction of the extruder motor, the settings in configuration.h are as follows:

#define INVERT_X_DIR true // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR true // for Mendel set to false, for Orca set to true
#define INVERT_E0_DIR true // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E1_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E2_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false

otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Re: Absolutely desperate

Post by otibook » Mon Aug 24, 2015 4:48 pm

Thank you very much Mark.

I am at work rigth now. I´ll try tonigth to modify the firmware as you post me.
Yesterday at nigth i have been checking the belts and upper bearings. Axis X anY belt touch on one side of the bearing support. I was triying to insert deeply the belts into the carriages. I hope that will be enough to eliminate the growls.

otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Re: Absolutely desperate

Post by otibook » Tue Aug 25, 2015 4:29 pm

Hi Mark.

Extruder motors reversed solved.
I´m still trying to solve the growls issue.

The calibration it´s impossible for the moment. I guess due the growls issue.

The "air printing" still remains.

THX

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Absolutely desperate

Post by Mark » Tue Aug 25, 2015 5:42 pm

The air printing , do you mean when doing G29, the probe "touches" in the air not the bed ?
Sometimes the probe would get stuck by the hole, and when it happened during the G29, the probe couldn't trigger the endstop anymore, and it ould cause this situation.

otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Re: Absolutely desperate

Post by otibook » Tue Aug 25, 2015 7:08 pm

When I send G29 command the probe touch the bed in 16 points, then when the spider moves to sides start the motors and belts start to growl. After this process if I send to print, the printer starts the work about 8 or 10 cm above the bed.

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Absolutely desperate

Post by Mark » Wed Aug 26, 2015 4:30 pm

It's so weird :o

otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Re: Absolutely desperate

Post by otibook » Wed Aug 26, 2015 5:16 pm

Yes it´s weird
I´ll send you a video tonigth.

otibook
Posts: 46
Joined: Thu Jul 23, 2015 12:47 am
Location: Madrid, Spain

Re: Absolutely desperate

Post by otibook » Thu Aug 27, 2015 8:09 am

That´s the link to the video of the terrible growls...

https://youtu.be/M_D4YIAN4yY

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Absolutely desperate

Post by Mark » Thu Aug 27, 2015 3:31 pm

Did you connect the probe enstop correct? It should connect pin 1and 3 .
How about skip the G29, could the printer work ?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests