LCD jam/ Control board broken

Post Reply
Posts: 0
Joined: Fri Sep 08, 2017 7:01 pm

LCD jam/ Control board broken

Post by Mothermilkman » Wed Dec 13, 2017 6:25 pm

Got myself a Prusa I3 pro B (GT2560+LCD2004)
After the initial upload of firmware the printer worked somewhat fine, but needed some tweaking and this is pretty much what i ended up with; The LCD2004 is locked is state shown in the pic and doesn't change no matter what I do. I've tried to re-up the firmware (pretty much all versions of arduino AND marlin), tried the same with two different computers (both win10), changed the ubs-cable, and several times updated port serial driver as well. I've tried with jumpers connected to board (Mega2560) and disconnected. But the firmware just doesn't seem to upload. I've examined the controller board by eye, but nothing seems scorched and amber led flashes during upload.. also, the reset-button on LCD doesn't have any effect whatsoever, nor the knob. Any ideas?


Edit: Hope links work now..

Upped, no solution yet
Last edited by Mothermilkman on Sun Dec 31, 2017 9:08 pm, edited 2 times in total.

User avatar
Site Admin
Posts: 6340
Joined: Tue Jun 07, 2016 9:38 am

Re: LCD jam/ Control board broken

Post by William » Thu Dec 14, 2017 11:46 am

I did not see the picture you mentioned, but I think you should check if the knob on the front of the LCD monitor is normal
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Post Reply