Problem with BL touch calibration

Post Reply
andyparla
Posts: 0
Joined: Wed Mar 14, 2018 7:21 pm

Problem with BL touch calibration

Post by andyparla » Wed Mar 14, 2018 8:03 pm

Hi everyone;

I have followed the wiki post from Bl Touch calibration:
http://www.geeetech.com/wiki/index.php/ ... alibration

But i am not able to make it:

I write the next commands as wiki says.

M851 ; note the number
it returns: -1.4

M851 Z0 ; set the offset to zero
it returns: Offset Zz_min: -15z_max:-5

G28;
It makes autohome; it tries go to 0 Z axis (but my bed is about 5mm) but the autoleveling does not work because the nozzle touch the hot bed and it does not stop. It have to manually stop

G1 Z0
it moves the Z to 0 mm

Then as per my bed is before the -1.4 value I try to set positive number in next command:
M851 Z2.0 ; to set the offset you got in the previous step.
It returns: it returns: Offset Zz_min: -15z_max:-5

M500 ; Stores the values in EEPROM so that it is not reset when you power the printer off and on.
And save.

So, I cannot use the bl touch because I dont know what happens.. i'm very frustrated

thanks for help me!

andyparla
Posts: 0
Joined: Wed Mar 14, 2018 7:21 pm

Re: Problem with BL touch calibration

Post by andyparla » Thu Mar 15, 2018 4:08 pm

OK, the problem was the Arduino board, it is a general issue for this board

My Geeetech Pro W comes with GT2560 A+ so the three pin that wiki says you have to connect at boardh is not valid. You have to connect it as below image I attached.

And you have to change in pins.h
Wiki says:
#define SERVO0_PIN 32//13 // untested

You must to put pin 11:
#define SERVO0_PIN 11//13 // untested

It works now, but I'm not able to calibrate.
when I write "G1 Z0" command bu the nozzel is far away from bed. my Z offset is -5 (the minumum value because my configuration.h support max -15 min -5) I cannot put -4 or less.

I hope anyone can help me I'm frustred.

thanks!
Attachments
arduinoGT2560A+BLTOUCH.jpeg
arduinoGT2560A+BLTOUCH.jpeg (45.84 KiB) Viewed 3867 times

User avatar
William
Site Admin
Posts: 5130
Joined: Tue Jun 07, 2016 9:38 am

Re: Problem with BL touch calibration

Post by William » Thu Mar 15, 2018 5:09 pm

I think you can refer to this post
viewtopic.php?f=20&t=19846
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

andyparla
Posts: 0
Joined: Wed Mar 14, 2018 7:21 pm

Re: Problem with BL touch calibration

Post by andyparla » Fri Mar 16, 2018 6:28 am

Yes i saw it but i dont know how to set my Z offset, it is always at same altitude. This firmware comes with -1.29 offset and it is so far away from my bed. I flashed +2, 3, 5 but nozzle is always at same position. So, i dont know how to calibrate it.

My Printer is the pro W, i know it is the same than pro B but i dont it this frimware is valid.

Thanks for your reply my friend

Lellos72
Posts: 2
Joined: Fri Dec 20, 2019 4:57 am

Re: Problem with BL touch calibration

Post by Lellos72 » Fri Dec 20, 2019 5:02 am

Hi, I have the same problem, and I wanted to know if you had solved the problem?


Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests