Page 1 of 1

How do I upload Marlin to a GT2560?

Posted: Sun Jul 14, 2019 9:25 am
by Ariovist
I bought a Geeetech GT 2560 Rev A+ for my i3 Pro B - Printer. I connected it correctly to the printer, turned it on, and just saw a blue screen with 2 white bars on it. So I assumed that the board didn´t have any firmware on it (can´t check that on the seller´s page bcause I forgot where I bought it). So I tried to upload the firmware like it said in the Geeetech Wiki (http://www.geeetech.com/wiki/index.php/GT2560), but nothing worked. I already had the red stepper drivers mounted onto it (A4899), and the only thing the board did was blinking (a yellow LED). So I tried uploading different versions of Marlin with different Versions of the Arduino IDE (1.0.1, 1.0.6, 1.8.6, 1.8.9, etc.). I changed the upload-speed in the boards.txt-file to 57600... Do I have to burn a bootloader onto the 2560 with another Arduino? What can I do now? Thx for your help!

Re: How do I upload Marlin to a GT2560?

Posted: Mon Jul 15, 2019 9:40 am
by William
Hi, do the three lights illuminate when the printer is normally turned on on your motherboard? Can you provide a specific picture of your motherboard? To better understand your problem.