PSU problem

Post Reply
buldo
Posts: 4
Joined: Wed Jan 04, 2017 4:57 am

PSU problem

Post by buldo » Wed Jan 04, 2017 5:13 am

Hi everyone,

I buy a prusa i3 and I have a problem with the Psu. When I apply 220 volt beetween the pin "L" and "AC" there is ov beetween the pin "com" and "v+".
I check the voltage with a voltmeter.
The green led power does not light up.
The switch inside the PSU is on 220V

Tell me if the PSU model S-180-12 is ok

Thanks for your help.

Tintek
Posts: 7
Joined: Wed Jan 04, 2017 3:25 am

Re: PSU problem

Post by Tintek » Wed Jan 04, 2017 2:50 pm

Hy!

I think that must be ok, you just need 12V DC for power look the original one but i think that is the 18A.

Did you check the input fuse in original PS, also check the solder on pins where you connect 220V AC

buldo
Posts: 4
Joined: Wed Jan 04, 2017 4:57 am

Re: PSU problem

Post by buldo » Fri Jan 06, 2017 8:00 pm

Thanks for your answer, I can't check the fuse because he is inside the psu who was sealed by a sticker for warranty. But only thing i can tell you that the fuse seems good (not interrupted) when i see through the cover grid.

It's the same thing for the pin sealed by stiker, but seems ok.

I think the psu has factory defective

User avatar
William
Site Admin
Posts: 4956
Joined: Tue Jun 07, 2016 9:38 am

Re: PSU problem

Post by William » Wed Jan 11, 2017 9:27 am

Hi,@buldo
How is it going?
Normally,the green led will light up when you switch on the power,and it should have DC output if you can have AC input on the PSU.
Otherwise the PSU has a problem.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

buldo
Posts: 4
Joined: Wed Jan 04, 2017 4:57 am

Re: PSU problem

Post by buldo » Thu Jan 12, 2017 4:06 am

Hi,@William
To resume the history , i have buy a prusa i3 with an official retailer.
On the first power on of the psu I can see there is a problem. My job is electrician that's why I'am sure the psu has a problem.
After I inform the retailer he request me to post a thread on this forum and (quote)" I will help you follow up with our technical colleague."

But there is no help and the retailer refuse to proceed exchange without agreement
(quote) "We can't resend if without the confirmation of our technical support."

I have no solution and i am waiting since 2 january ...

User avatar
William
Site Admin
Posts: 4956
Joined: Tue Jun 07, 2016 9:38 am

Re: PSU problem

Post by William » Fri Jan 13, 2017 5:04 pm

Hi,@buldo
What is your seller's name?
I guess you bought it on Ebay from Geeetech-official?
If you did,attach your email address and maybe i can help you contact the seller?
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

buldo
Posts: 4
Joined: Wed Jan 04, 2017 4:57 am

Re: PSU problem

Post by buldo » Sat Jan 14, 2017 5:44 pm

Hi William, PM sent :)

walterfantauzzi
Posts: 6
Joined: Thu May 11, 2017 3:41 am

Re: PSU problem

Post by walterfantauzzi » Wed May 17, 2017 4:00 am

Hi Guys,

I've the same issues. So I've buy the Prusa i3 MK8 on ebay, and I wrote to the seller but he doesn't reply to me.
Image


How Can I do?

thanks
W.

User avatar
William
Site Admin
Posts: 4956
Joined: Tue Jun 07, 2016 9:38 am

Re: PSU problem

Post by William » Wed May 17, 2017 1:21 pm

buldo wrote:Hi everyone,

I buy a prusa i3 and I have a problem with the Psu. When I apply 220 volt beetween the pin "L" and "AC" there is ov beetween the pin "com" and "v+".
I check the voltage with a voltmeter.
The green led power does not light up.
The switch inside the PSU is on 220V

Tell me if the PSU model S-180-12 is ok

Thanks for your help.
Your PSU is dead.
Just contact the related seller and replace a new one!
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

walterfantauzzi
Posts: 6
Joined: Thu May 11, 2017 3:41 am

Re: PSU problem

Post by walterfantauzzi » Wed May 17, 2017 2:59 pm

William wrote:
buldo wrote:Hi everyone,

I buy a prusa i3 and I have a problem with the Psu. When I apply 220 volt beetween the pin "L" and "AC" there is ov beetween the pin "com" and "v+".
I check the voltage with a voltmeter.
The green led power does not light up.
The switch inside the PSU is on 220V

Tell me if the PSU model S-180-12 is ok

Thanks for your help.
Your PSU is dead.
Just contact the related seller and replace a new one!
Yes the Geeetech techincal support reply to me now by email. So I would like to let you know that me and a my friend engineer measured the current absorption with a current meter about the Prusa i3 MK8 and we've seen that it is higher than the 15A delivered by the PSU. The supplied PSU is underdimensional!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest