Page 1 of 1

Something about About low temperature repair

Posted: Mon Dec 02, 2019 1:27 pm
by Admin
Hi, guys.
something about the low-temperature repair.
you can refer to this link;
A20T_G05_V1.1.8_2.rar
(121.52 KiB) Downloaded 188 times

Re: Something about About low temperature repair

Posted: Sat Dec 07, 2019 7:17 am
by ericarenee
How do we use this to update the printer.

I seem to not be able to get it to work .

Re: Something about About low temperature repair

Posted: Mon Dec 09, 2019 12:42 am
by ericarenee
Has anyone actually flashed firmware on the a20t printer.

It seems everyone is posting Common procedure for flashing firmware on geeetech devices. It shows match baud rate and 112 as the rate. but the geetech a20t inside its about on the printer itself it says 250000 ... I really do believe this is the issue..

Can someone Who actually owns this exact printer that has flashed this post and give there exact procedure how it worked. NOT Those who own other geeetech printers.

I have been working on this for over a week and about to send it back as its useless to me only able to print 1 color unless you stand next to it as changing the g-code to never turn the hot end heating off is not a real solution.
I have other 3d printers and never had a issue updating firmware on them.

Thank you in advance for any a20t printer owners..

Erica .

Re: Something about About low temperature repair

Posted: Mon Dec 09, 2019 9:43 am
by William
ericarenee wrote:
Mon Dec 09, 2019 12:42 am
Has anyone actually flashed firmware on the a20t printer.

It seems everyone is posting Common procedure for flashing firmware on geeetech devices. It shows match baud rate and 112 as the rate. but the geetech a20t inside its about on the printer itself it says 250000 ... I really do believe this is the issue..

Can someone Who actually owns this exact printer that has flashed this post and give there exact procedure how it worked. NOT Those who own other geeetech printers.

I have been working on this for over a week and about to send it back as its useless to me only able to print 1 color unless you stand next to it as changing the g-code to never turn the hot end heating off is not a real solution.
I have other 3d printers and never had a issue updating firmware on them.

Thank you in advance for any a20t printer owners..

Erica .
Hi, If you are unable to update the firmware, you can contact your sales representative to replace the motherboard.

Re: Something about About low temperature repair

Posted: Tue Dec 10, 2019 4:09 am
by ericarenee
Thank you .

I actually was able to get it to update using a very old Core 2 Duo Computer. Its odd that apparently it did not like None of our high end Thinkpad Laptops. none of the 3 of them would work.

BAD NEWS.

The flash did not solve the issue . I am starting to lean toward its not a firmware issue but a issue with slicer programs not compatible with 3 extruders.
Adding the Post process scrip Find and replace M104 REPLACE WITH ; WORKS..

But would like a real fix not a patch as The printer hot end does not cool at the end of the print.. I am afraid if something goes wrong it will clog print head, Over heat ptfe tube or worse..


Thanks everyone for trying to look into this. I am Sure that as more people start using this machine a fix will be found...

Re: Something about About low temperature repair

Posted: Mon Dec 16, 2019 5:11 am
by celer
ericarenee wrote:
Tue Dec 10, 2019 4:09 am
Thank you .

I actually was able to get it to update using a very old Core 2 Duo Computer. Its odd that apparently it did not like None of our high end Thinkpad Laptops. none of the 3 of them would work.

BAD NEWS.

The flash did not solve the issue . I am starting to lean toward its not a firmware issue but a issue with slicer programs not compatible with 3 extruders.
Adding the Post process scrip Find and replace M104 REPLACE WITH ; WORKS..

But would like a real fix not a patch as The printer hot end does not cool at the end of the print.. I am afraid if something goes wrong it will clog print head, Over heat ptfe tube or worse..


Thanks everyone for trying to look into this. I am Sure that as more people start using this machine a fix will be found...
I guess the question I'd ask is does it print the test prints on the included SD card OK - If so it may be a slicer issue? I have one of these printer as well and outside of stringing and blobs haven't had any issues with getting it to print, even while mixing on all 3 extruders (I'm using Simplify3D).

To me it sounds like the "Temperature too low error" is likely a voltage issue with the power supply or motherboard. I'd test this theory by doing prints which incrementally add in more of the extruders, i.e. print with E0, then add in E1, then add in E2, and then swap the order of the extruders and how they are added in, if the issue occurs when there is more load on the printer then to me that would indicate it's a stability issue with the motherboard or power supply.

Re: Something about About low temperature repair

Posted: Mon Dec 16, 2019 5:51 am
by ericarenee
The Temp to low issue is a Slicing issue. But it exist because of the Printers Firmware not knowing its a 3 extruder printer. When the first extruder starts printing its last layers the it starts a cool down cycle. When its time for the second extruder to start printing the machine temp is to low causing it to halt and throwing the error. IF it were a voltage or other electrical or connection issues it would HAPPEN Randomly.. The issue is at the FINAL Tool change . As i posted in the work around fix for this there is obviously not a hardware failure. But a failure in The printers firmware not having any logic related to more then 1 extruder. The extruder o1 and o2 on this machine are Virtual extruders in the Slicers G-CODE.. They are not True extruders known the Printer itself.

On your printer Try to print with Just extruder o1 or 02 .. Without using oo ....

Let me know the results of each combination ..

I have it working and i can print with it now. But only by hackish g-gode post processing telling it to NOT Turn any temp off.

I have also changes all 3 of those extruders to TRUE METAL BMG .

The printer Prints near perfect with the fixes .. The slight stringing and Blobs is less after the extruder swap.. Still messing with travel speed and coasting settings to work out blob issue .