Linear advance, extruder very noisy

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Tue Nov 26, 2019 3:33 pm

Following.
Unless I am missing something, I still cannot get the Ozze strainging off from my prints....
disks are off
Retraction seemed to be non effect
Temp for play lowered to 185c travel to 200......
I can see that the pressure is still squeezing out filament when retraction and travel to the purge bucket causing looooong strainging..... :x
any suggestion.....
Thanks

DzzD
Posts: 79
Joined: Sat Oct 19, 2019 5:52 pm

Re: Linear advance, extruder very noisy

Post by DzzD » Tue Nov 26, 2019 5:57 pm

I can see that the pressure is still squeezing out filament when retraction and travel to the purge bucket causing looooong strainging..... :x
All Purge Bucket script I have found was not working well (especially tool retractation), so I had to make my own and everything work well now.

Here is a the script I use and which perform nice retraction on tool change:

Code: Select all

;; Start custom tool change script
M211 S0;
G92 E0 ; Reset extrusion distance on old too
G1 E-6 F1800 ; Retract filament
G92 E0 ; Reset extrusion distance on old too
G91 ; Switch from absolute positioning to relative positioning
G1 Z1 F1000 ; Lift nozzle by 1 mm in relative positioning mode
G90 ; Return to absolute positioning
G1 X-9.5 F[travel_speed] ; Go to X=-9.5 at 100 mm/sec
T[new_tool]
G92 E0 ; Reset extrusion distance on new tool
G1 E40 F180 ; Extrude x mm of filament at 3 mm/s on new tool
G1 E50 F60 ; Extrude slower (release pressure)
G92 E0 ; Reset extrusion distance on new tool
G1 E-6 F1800 ; Retract filament 
G1 X[next_position_x] Y[next_position_y] F[travel_speed] ; Move to next position on print
G1 Z[next_position_z] F1000 ; Move to next position Z on print 
G1 E0 F1800 ; Un-Retract filament 
G92 E0 ; Reset again extrusion distance
M211 S1
;; End custom tool change script
Also, you MUST set "Tool change retraction distance" to 0 (disabled) in the "Other" tab
Attachments
ToolRetraction.JPG
ToolRetraction.JPG (16.44 KiB) Viewed 655 times

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Tue Nov 26, 2019 9:29 pm

Thanks Man!! Will try today!!
Crossing my fingers!!!
Really appreciate your help!

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Tue Nov 26, 2019 9:38 pm

May I know what is your retraction setting ?
Thanks again

Jarda3d
Posts: 184
Joined: Sat Jan 26, 2019 8:42 am

Re: Linear advance, extruder very noisy

Post by Jarda3d » Wed Nov 27, 2019 7:26 am

Try my A10M profile for dual colour print. Put your actual lilament multiplier and restraction lowered in same manner.
A10M Slic3r profile: here and fresh on github (lot of tips here)
A10 Slic3r profile: here
TIP: tight all screws and wheels (except right side of Z axis) and re-align frame while assembly. And silence it.

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Wed Nov 27, 2019 8:29 am

thanks... I think I have done that...
but I'm concentrating on S3D's for the moment....
I did sliced the astronaut Phil using Slicer PE... still massive straining
If Failing S3D, I will revisit Slicer....ha, on my computer the slicer crashes... Now I remember.

DzzD
Posts: 79
Joined: Sat Oct 19, 2019 5:52 pm

Re: Linear advance, extruder very noisy

Post by DzzD » Wed Nov 27, 2019 4:04 pm

3DAngel wrote:
Wed Nov 27, 2019 8:29 am
thanks... I think I have done that...
but I'm concentrating on S3D's for the moment....
I did sliced the astronaut Phil using Slicer PE... still massive straining
If Failing S3D, I will revisit Slicer....ha, on my computer the slicer crashes... Now I remember.
Attached to this post a pre-sliced two color model (print time 30mm), if you still get stringing with this print you probably have a hardware or filament issue because this model print fine without stringing on my A20m.
Attachments
Cone.zip
(1.08 MiB) Downloaded 25 times

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Thu Nov 28, 2019 11:14 pm

Thanks Dzzd
Will try today.
Appreciated very much!!!!

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Fri Nov 29, 2019 1:09 am

DzzD wrote:
Wed Nov 27, 2019 4:04 pm
Attached to this post a pre-sliced two color model (print time 30mm), if you still get stringing with this print you probably have a hardware or filament issue because this model print fine without stringing on my A20M.
It is looking great...
I can hear and see the differences...
definitely it is S3D and slicing settings and my hardware issue in combination....
- slicer S3d : that I haven't get it right/tuned.
- extruder issue with old design pressure lever binding to the stepper motor shaft causing erratic retraction and return to E0 position to properly extrude.
replaced with BMG and now hardware works great.

is it possible to have your S3D's fff profile?

Much appreciated for your help!!

3DAngel
Posts: 76
Joined: Tue Aug 06, 2019 2:04 pm

Re: Linear advance, extruder very noisy

Post by 3DAngel » Fri Nov 29, 2019 11:28 am

@DzzD

never mind

you already did...
from the cone's gcode ..

Thanks!!!!!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests