New A20M Probelm

Post Reply
Posts: 11
Joined: Mon Jun 22, 2020 1:14 pm

New A20M Probelm

Post by kailee_olson » Sat Mar 27, 2021 4:13 pm

I got my A20M about a week ago from amazon, Everything worked great initially.
Suddenly it no longer detects the SD card. Tried 3 or 4 that I have here and nothing.
So I've been using Octoprint with a raspi 3b+. Not as good results a from the sd but ok.

Now the button no longer works at the panel, I hear it click, but nothing. Of course I pwr cycled & press the little reset button.
I was thinking just now maybe it disables this stuff while plugged into usb? I have other printers and they don't do this.

So I would guess my next step is to disassemble it & check connections? This all was pre-assembled, so if they're loose they cam this way.
Or maybe I need another LCD board? They seem cheap enough, but I shouldn't have to be buying replacement parts for a 1 week old printer.

If there any tips for getting octoprint working better in the meantime that would help. Or can I run Eazyprint on a PI? text to speech

The other little problem I have is the #2 extruder pumps out alot less than the #1. I took apart the mech and tightened it up some, and cranked up the flow on that side to workaround. 150%. They still don't seem equivalent, but closer.

Otherwise I'm very happy with the quality, much better than my other machines.

Thanks for the help!

Posts: 7
Joined: Sun May 26, 2019 5:52 pm

Re: New A20M Probelm

Post by Lhindu » Mon Apr 05, 2021 12:59 am

In the past i have the same issue, in my case the problem was the SD card slot, it was broken and restarted the communication, so now i only print with the usb, probably reinforcing the support it will stop the problem.
For the extruder just chech the step/mm.... must be 430, and re-check the thightness.
Hope this can help you

User avatar
Posts: 380
Joined: Wed Nov 30, 2011 9:49 am

Re: New A20M Probelm

Post by Admin » Thu Apr 08, 2021 4:01 pm

Hello, if the printer cannot recognize the SD card, there may be a problem with the SD card slot on the motherboard. It may be loose. Please try to press it to see if it can return to normal.
If you need replacement parts, please contact geeetech via ticket.

Posts: 2
Joined: Mon Mar 02, 2020 3:52 pm

Re: New A20M Probelm

Post by finacoles2 » Sat May 08, 2021 4:06 pm

So, I had a stepper driver short out upon first start up. They sent me a new motherboard without the driver I need, I know it is a geeetech gt2560 v4 board. The problem is that they can't find what driver it is that I need. Does anyone have any ideas where I can find them without buying a motherboard with them?

Post Reply