Display damaged?

Post Reply
unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Display damaged?

Post by unrealgf » Fri Feb 14, 2020 5:03 am

hi all,
my display no longer shows anything. it glows but but no font is displayed.
what is wrong? display or mainboard damaged?

User avatar
William
Site Admin
Posts: 6188
Joined: Tue Jun 07, 2016 9:38 am

Re: Display damaged?

Post by William » Fri Feb 14, 2020 9:02 am

Hi,you can try to reconnect the screen cable, then check if the printer is turned on normally, if there is any ve vb 5v light on the motherboard.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Fri Feb 14, 2020 2:08 pm

William wrote:
Fri Feb 14, 2020 9:02 am
Hi,you can try to reconnect the screen cable, then check if the printer is turned on normally, if there is any ve vb 5v light on the motherboard.
i reconnected the screen cabel and the printer was turned on but display was without any fonts.
switched off and than i moved the cable back and forth and that helped.
ve and vb lights are on, no matter whether it shows font or not.

User avatar
William
Site Admin
Posts: 6188
Joined: Tue Jun 07, 2016 9:38 am

Re: Display damaged?

Post by William » Sat Feb 15, 2020 8:56 am

Hi,is your 5v light on? The reason for reconnecting the screen wiring may be the loose screen cable.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Sun Feb 16, 2020 5:53 am

which one is that?
Attachments
20200215_224325.jpg
20200215_224325.jpg (177.48 KiB) Viewed 5649 times

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Sun Feb 16, 2020 6:05 am

and after one day working display was that on it. restarted the printer and now again is the display without any font.
Attachments
20200215_225359.jpg
20200215_225359.jpg (416.28 KiB) Viewed 5649 times

User avatar
William
Site Admin
Posts: 6188
Joined: Tue Jun 07, 2016 9:38 am

Re: Display damaged?

Post by William » Sun Feb 16, 2020 9:20 am

Hi,Your motherboard display is normal, you can try to press and hold the reset button under the screen.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Sun Feb 16, 2020 6:26 pm

my matherboard and display are normal?? realy???
Attachments
20200216_111952.jpg
20200216_111952.jpg (120.39 KiB) Viewed 5634 times

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Sun Feb 16, 2020 7:25 pm

vert wrote:
Sun Feb 16, 2020 7:20 pm
a garbled display is usually firmware settings usually the addition of more delay to the screen fix's it but given the total lack of showing anything the cable could be bad.
how can i fix it, i´m on newest merlin bugfix 2.0.x?

unrealgf
Posts: 8
Joined: Fri Feb 14, 2020 4:50 am

Re: Display damaged?

Post by unrealgf » Sun Feb 16, 2020 10:53 pm

vert wrote:
Sun Feb 16, 2020 7:44 pm
have a look at my github see example of the delay.
https://github.com/Vertabreak/Marlin
or better yet use my fork.
have changed cable and used ur soft, nothing helped. I also measured the connection(pin to pin) between matherboard and display, it is ok.
so i think the display is fucked up.
i can print over the repetier-host soft but nothing on display :roll:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests