Customer Service

acmenw
Posts: 4
Joined: Fri Sep 11, 2015 8:37 pm

Customer Service

Post by acmenw » Fri Nov 13, 2015 5:05 am

Customer Service claims - We will reply your email within 24 hours! 7 days a week, 365 days a year support! We take customer service seriously and want you to be 100% happy with your shopping experience.

Who do I contact since customer service has not responded to any of my emails.

Signed
Not Happy

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Customer Service

Post by Mark » Fri Nov 13, 2015 4:26 pm

Hi could you tell me what your problem is?

acmenw
Posts: 4
Joined: Fri Sep 11, 2015 8:37 pm

Re: Customer Service

Post by acmenw » Fri Nov 13, 2015 8:16 pm

I have a Pro C with a metal MK8 Dual extruder holder. The extruded x axis carrier broke in half and I want it replaced.

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Customer Service

Post by Mark » Sat Nov 14, 2015 9:55 am

Do you have a picture here? tell me your order number and purchase place, maybe I can help you to contact the sales for you.

acmenw
Posts: 4
Joined: Fri Sep 11, 2015 8:37 pm

Re: Customer Service

Post by acmenw » Tue Nov 17, 2015 4:16 am

I bought it off your website.
What happen to the other emails I sent to After-sales Service?

Order NO:20150912142932263
Unassembled-Geeetech i3 pro C dual extruder 3D printer
Nozzle Size: 0.4mm
Filament material: PLA
Filament size: 1.75mm
Acrylic colors: black

acmenw
Posts: 4
Joined: Fri Sep 11, 2015 8:37 pm

Re: Customer Service

Post by acmenw » Tue Nov 17, 2015 4:23 am

This is the part that lost a post and cracked in half.
Attachments
part.png
part.png (273.87 KiB) Viewed 9088 times

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Customer Service

Post by Mark » Wed Nov 18, 2015 3:03 pm

I have contact the seller for you, thanks for your patience!

lowfiero
Posts: 2
Joined: Mon Dec 14, 2015 2:35 am

Re: Customer Service

Post by lowfiero » Mon Dec 14, 2015 2:40 am

i have a i3 pro c and when i got the kit i was missing a part. the one the motor on the left side mounts too. i did get 2 of the other side. also the power supply isnt working. it worked for about 19 mins and then stopped. it has come on a couple of times but never stays on long.
i did use the other extra part to get it together but without the power supply i am dead in the water.
i have sent a couple of messages and emails and have not heard anything back for the past couple of weeks.
would like to hear something at some point.
Thank you

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Customer Service

Post by Mark » Mon Dec 14, 2015 2:09 pm

you can send the pictures and the problem to this mailbox: technical<technical@geeetech.com>, they will reply to you as soon as possible.

lowfiero
Posts: 2
Joined: Mon Dec 14, 2015 2:35 am

Re: Customer Service

Post by lowfiero » Wed Dec 30, 2015 3:04 am

Thank you,
after a couple of emails i have a new power supply and the printer is up and running.
never did get the part that wasnt in the kit but was able to use the extra one to put the printer together. should be no problem with the operation of the pinter.
now just to get the setup all done and get to printing.
Thanks again Mark for helping me out and getting my printer up and running.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests