Reflash Bootloader on GT2560

mava70
Posts: 20
Joined: Sun Nov 01, 2015 8:20 am

Reflash Bootloader on GT2560

Post by mava70 » Mon Nov 02, 2015 9:38 pm

Hello,

is it possible to reflash bootloader of 2560 in my GT2560? I don't find a suitable ICSP interface, could you please provide a pinout?

thanks

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Reflash Bootloader on GT2560

Post by Mark » Tue Nov 03, 2015 4:27 pm

It seems there's no ICSP pin for you to reflash the Bootloader on GT2560...

mava70
Posts: 20
Joined: Sun Nov 01, 2015 8:20 am

Re: Reflash Bootloader on GT2560

Post by mava70 » Tue Nov 03, 2015 4:40 pm

Yep, maybe there is some hidden pins to connect

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Reflash Bootloader on GT2560

Post by Mark » Tue Nov 03, 2015 6:04 pm

So which pin do you want for this? I can help you to find out for you.

mava70
Posts: 20
Joined: Sun Nov 01, 2015 8:20 am

Re: Reflash Bootloader on GT2560

Post by mava70 » Wed Nov 04, 2015 11:07 pm

Hello,

I found this doc

http://reprap.org/wiki/Geeetech_GT2560

comparing to ICSP socket
Image

It seams that sd card has some useful pin for ICSP isn't it?

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Reflash Bootloader on GT2560

Post by Mark » Thu Nov 05, 2015 3:41 pm

Yes exactly. But this is the old one, check the new one here:
QQ截图20151105154956.jpg
QQ截图20151105154956.jpg (413.8 KiB) Viewed 22208 times
SD PIN.jpg
SD CARD
SD PIN.jpg (262.12 KiB) Viewed 22108 times
LCD PIN.jpg
LCD
LCD PIN.jpg (262.29 KiB) Viewed 22108 times

lymphomaniac1
Posts: 2
Joined: Thu Jan 21, 2016 11:24 am

Re: Reflash Bootloader on GT2560

Post by lymphomaniac1 » Thu Jan 21, 2016 11:39 am

I have a gt2560 board that does not communicate with my PC through the USB port. It shows up in the device manager as (COM4) but does not say "Arduino". When trying to load firmware onto the board everything times out. I am sure that the GT2560 board need to have the bootload reinstalled. I bought a USB AVR ISP Programmer to load the bootload onto the board. I see where the MOSI, Reset, SCK, MISO and Ground plug into both the AVR ISP programmer and GT2560 card. My AVR ISP programmer cardalso has VCC and N/C pins I do not see where the corresponding VCC and N/C pins on the GT2560 are located. Could somebody help me here? Please do not laugh at my question, I am a novice at this stuff.

Thanks,

Stuart

mava70
Posts: 20
Joined: Sun Nov 01, 2015 8:20 am

Re: Reflash Bootloader on GT2560

Post by mava70 » Fri Jan 22, 2016 1:12 am

Hi,

My board was fautly checking with oscilloscope the oscillator I don't have any signal. Swapped oscillator but nothing, I fear you have same problem.

Marco

olliesmith
Posts: 2
Joined: Sun Mar 27, 2016 6:22 am

Re: Reflash Bootloader on GT2560

Post by olliesmith » Sun Mar 27, 2016 6:44 am

Thanks for the info guys, i successfully managed to get this board back to life using an arduino 2560 as an isp. can be done with other arduinos

How i fecked it up.
i chose "export compiled binary" method from arduino and updated the printers firmware via repetier server. it worked the first time but the second time i chose the blablabla-bootloader.hex instead of blablabla.hex. this screwed me over.

How I fixed It.
bang head against wall, connect relevant pins (sck, mosi, miso, vcc, gnd) from ICSP header to the pins on the gt2560 board (picture from post above). (ribbon cables reverse the pinout)
digital pin 10 on arduino to reset on gt2560 (sd connetor).

in arduino (i used 1.6.8), load arduinoisp from examples and write to arduino,

choose "arduino as isp" under tools -> programmer, make sure arduino is correct com port

tools -> burn bootloader, if it says invalid signature there is a wiring mistake

dandantas
Posts: 9
Joined: Thu Dec 03, 2015 7:05 pm

Re: Reflash Bootloader on GT2560

Post by dandantas » Wed Apr 06, 2016 9:02 am

hello
i guess i mess up my bootload also!
during adjust of step/mm in repetier =(

@olliesmith you say you use arduino to burn the bootload again, but bootload of arduino mega 2560 doesnt have fuse settings for external oscilator (cause there isnt any for the main chip on the arduino board)!!

i tried the connetion with arduino isp on UNO and MEGA without sucess =(
now i'm working with an usbasp and kept signture at 0x620000 or 0x5e0000, but no sucess on comunication!

did you plug any out power to the gt2560, besides 5v of the arduino isp on the LCD connector?

thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest