A10M display is green. No text is shown

Moderator: vert

Post Reply
damith
Posts: 2
Joined: Thu Aug 29, 2019 1:19 pm

A10M display is green. No text is shown

Post by damith » Thu Aug 29, 2019 1:28 pm

Hi. It was after a long print of around 25 hours. and the printer was kept powered for another 6-7 hours even after the print was finished.
After switched on again it was okay for few minutes (until the hot-end pre heated) and suddenly the text on the display were disappearing and shown very very light black. after some time the display started dimming and brightning. when switched off and switch on back, the display shows the ' merlin 1.1.8 ' message and then its full green, no text. still some dimming occurs and some time later turns itself off. the fans are working. the lights of the mother board are lightning. the voltage output of the power supply is 24v and around 24v all the time. Please help me to figure this out. Thank you in advance!
Attachments
IMG_8751.jpg
IMG_8751.jpg (247.8 KiB) Viewed 2027 times
Last edited by damith on Thu Aug 29, 2019 1:36 pm, edited 1 time in total.

User avatar
William
Site Admin
Posts: 5981
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M display is green. No text is shown

Post by William » Thu Aug 29, 2019 1:35 pm

Hi, You can
1. Reconnect the screen cable;
2. Check if there are three lights on the motherboard when the printer is turned on normally. You can refer to this:
v3板正常情况.jpg
v3板正常情况.jpg (221.89 KiB) Viewed 2027 times
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

damith
Posts: 2
Joined: Thu Aug 29, 2019 1:19 pm

Re: A10M display is green. No text is shown

Post by damith » Thu Aug 29, 2019 1:39 pm

@williams. thank you verymuch for your reply. I re connected the display's connector. I will check the bulbs of the mother board now. How can we know the mother board is good or gone? I tried to re upload the firmware but it didnt get uploaded

User avatar
William
Site Admin
Posts: 5981
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M display is green. No text is shown

Post by William » Thu Aug 29, 2019 1:43 pm

damith wrote:
Thu Aug 29, 2019 1:39 pm
@williams. thank you verymuch for your reply. I re connected the display's connector. I will check the bulbs of the mother board now. How can we know the mother board is good or gone? I tried to re upload the firmware but it didnt get uploaded
Hi, If it is normal, the vb ve 5v light will be on the motherboard.
If one of them is not lit, the motherboard may have a problem and need to be replaced.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

nvnazeer
Posts: 4
Joined: Sun Jan 06, 2019 11:11 pm

Re: A10M display is green. No text is shown

Post by nvnazeer » Sun Nov 03, 2019 7:15 pm

Hi, I have the same problem. Display is green no text and also USB connection is not detected by P.C.
The printer was working fine before this with no issues. However when I shifted residence I had dismantled and reinstalled when there was a pop sound on restarting. Then I noticed one of the cable was wrongly connected and I fixed that.
However now I have this green display and non-functional USB port. I have not made any changes on the board and the the three red leds are lit. . Checked the ribbon cable connections they are fine. Power is also available on the display unit(4.9V).
Please let me know if need to check anything and guide me to get my A10M working again.

Thanks and regards

Nazeer N.V

User avatar
William
Site Admin
Posts: 5981
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M display is green. No text is shown

Post by William » Mon Nov 04, 2019 9:16 am

Hi, you can try to reconnect the screen cable.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

nvnazeer
Posts: 4
Joined: Sun Jan 06, 2019 11:11 pm

Re: A10M display is green. No text is shown

Post by nvnazeer » Tue Nov 05, 2019 2:25 am

I have tried that already, No change. Its still the same.
Thank you for the response.

User avatar
William
Site Admin
Posts: 5981
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M display is green. No text is shown

Post by William » Tue Nov 05, 2019 9:20 am

Hi, If the usb port is not recognized, you can try to install the driver manually: https://www.geeetech.com/forum/viewtopi ... RlcFtWdCG4
If it still cannot be read, there may be a problem with the motherboard port.

For screen questions, you can refer to this: viewtopic.php?f=23&t=17040
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

nvnazeer
Posts: 4
Joined: Sun Jan 06, 2019 11:11 pm

Re: A10M display is green. No text is shown

Post by nvnazeer » Thu Nov 07, 2019 1:51 am

Thank you for replying.
The USB and display was working few days back. When I did reassembly of the printer I connected the Z axis cable to the ports between the rollers of the y axis. There was a sound and then the display and USB cable problem started.
I have already reinstalled the USB drivers, still no change. How can i fix the issue, if there is problem on the USB motherboard connection. Will I need to change the motherboard completely?
Is it possible that both the USB and display fail at the same time. Are they connected from the same power source or for any other reason.
Will this get resolved if I change the display and the ribbon cable? Please advise.

Best regards

Nazeer N.V

User avatar
William
Site Admin
Posts: 5981
Joined: Tue Jun 07, 2016 9:38 am

Re: A10M display is green. No text is shown

Post by William » Thu Nov 07, 2019 9:10 am

:D Hi, you can reconnect the USB cable to connect.
If you still can't connect, it may be caused by a problem with the communication port of the motherboard.
You can check if your screen wiring is broken or not.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests