Fan problem during operation.

Moderator: vert

AFewSkroosLoose
Posts: 35
Joined: Sat Sep 01, 2018 8:07 pm

Re: Fan problem during operation.

Post by AFewSkroosLoose » Mon Sep 03, 2018 9:45 pm

I have used both slic3r and cura with same result. Fan also can not be run using knob on LCD Temp>Fan. Since fan will not work with knob, I dont think problem is with slicer. I am thinking it is board connection wrong maybe? Thank you for responding. Printer is good but will be awesome with part cooling.

User avatar
_kaktus_
Site Admin
Posts: 1257
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: Fan problem during operation.

Post by _kaktus_ » Mon Sep 03, 2018 9:56 pm

Hi
:mrgreen:

Gentlemen, I propose the simplest possible solution to the test :roll:

Use the Gcode command to run this fan :!:

:D
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

AFewSkroosLoose
Posts: 35
Joined: Sat Sep 01, 2018 8:07 pm

Re: Fan problem during operation.

Post by AFewSkroosLoose » Mon Sep 03, 2018 10:01 pm

Which gcode command to test the fan? I will insert it into one of my files if I know what command tocuse and try it. Thanks.

User avatar
_kaktus_
Site Admin
Posts: 1257
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: Fan problem during operation.

Post by _kaktus_ » Mon Sep 03, 2018 10:08 pm

:D
I recommend reading my manuals on how to run the fans in my printer.
You will certainly find something interesting for yourself, even though our printers are different.

Look into M201 subforum. ;)
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

AFewSkroosLoose
Posts: 35
Joined: Sat Sep 01, 2018 8:07 pm

Re: Fan problem during operation.

Post by AFewSkroosLoose » Mon Sep 03, 2018 10:15 pm

Kaktus thanks I will look through your m201 write ups.

zonalimitatore
Posts: 78
Joined: Tue Aug 28, 2018 7:12 am
Location: Italy

Re: Fan problem during operation.

Post by zonalimitatore » Mon Sep 03, 2018 10:20 pm

Code: Select all

M106 P0 S255*16
or just

Code: Select all

M106 S255

AFewSkroosLoose
Posts: 35
Joined: Sat Sep 01, 2018 8:07 pm

Re: Fan problem during operation.

Post by AFewSkroosLoose » Tue Sep 04, 2018 3:23 am

Okay I figured it out but still not right. Fan must be set to 100% (255) in all cases of slicer settings. Knob on lcd must go to 255 (not even 254) to work...it is only 100% on or 100% off, so really not PWM controlled for experimentation and adjusting with lower speeds. Youtube video "a10 fan weak" suggests fan is 24v fan and only receiving 12v so must be set to max at all times. Maybe try a 12v fan to see if full PWM control will then work. This should be corrected by Geetech to get full PWM control of part cooling fan, yes? Or am i still misunderstanding? Thanks for your help - at least i have some ability to turn on now.

zonalimitatore
Posts: 78
Joined: Tue Aug 28, 2018 7:12 am
Location: Italy

Re: Fan problem during operation.

Post by zonalimitatore » Tue Sep 04, 2018 4:22 am

Yep.Or on or off....i dont know why implement pwm and mount a non controlled fan :roll:

User avatar
_kaktus_
Site Admin
Posts: 1257
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: Fan problem during operation.

Post by _kaktus_ » Tue Sep 04, 2018 11:37 pm

Hi
:mrgreen:
zonalimitatore wrote:
Tue Sep 04, 2018 4:22 am
Yep.Or on or off....i dont know why implement pwm and mount a non controlled fan :roll:
I also don't understand why you are saying that.
To my knowledge, it is possible to control the fan speed smoothly, which has only two wires connected, e.g. +12V and GND.

This was the solution used by the manufacturer. :P

If you are interested in details how it works, it is worth reading a little. ;)

zonalimitatore wrote:
Mon Sep 03, 2018 10:20 pm

Code: Select all

M106 P0 S255*16
or just

Code: Select all

M106 S255
I wonder where you got the part of the parameter *16 :?:
Parameters
Pnnn Fan number
Snnn Fan speed (0 to 255)
Sours.

I have a control without it :!:
In my opinion it is wrong and the whole command in this form is ignored by the interpreter.
Would you like to explain to me?

;)
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

User avatar
MichaelK
Posts: 43
Joined: Thu Mar 22, 2018 5:20 pm
Location: Germany

Re: Fan problem during operation.

Post by MichaelK » Wed Sep 05, 2018 1:15 am

To test the part cooling fan, you could use the following code: M106 S255
M106 - set fan speed. S255 full speed, S127 50% speed, S0 stop fan.

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests