A10 firmware problem

Moderator: vert

ade
Posts: 1
Joined: Mon Aug 13, 2018 10:39 pm

A10 firmware problem

Post by ade » Mon Aug 13, 2018 10:45 pm

Hi guys, im trying to update the firmware on my new A10. I keep getting error code that says using typedef-name 'fpos_t' after struct

Im very new to this so any help would be appreciated. thanks ade

jonA10
Posts: 7
Joined: Tue Aug 07, 2018 10:42 pm

Re: A10 firmware problem

Post by jonA10 » Wed Aug 15, 2018 10:18 am

Hi
If you will use to FW 1.0.4. My advice is don’t do it. Its still a buggy. But if you still want to try use arduino ver 1.0.1

User avatar
MichaelK
Posts: 43
Joined: Thu Mar 22, 2018 5:20 pm
Location: Germany

Re: A10 firmware problem

Post by MichaelK » Mon Aug 20, 2018 6:27 pm

Hello.

You can use my own firmware based on Marlin 1.1.8: (Firmware files included in project)
https://www.thingiverse.com/thing:3020915

Or you can look to github: https://github.com/Geeetech3D

paultbg
Posts: 8
Joined: Thu Aug 23, 2018 2:29 pm

Re: A10 firmware problem

Post by paultbg » Thu Aug 30, 2018 10:36 pm

It looks like the "official" firmware for the A10 is broken and will not compile.I get a strange error starting with :

Code: Select all

"In file included from sketch\Marlin.h:21:0,

                 from sketch\Marlin_main.cpp:30:

pins.h:1404:32: error: pasting "/*PIN that has to be turned on right after start, to keep power flowing.*/" and "_DDR" does not give a valid preprocessing token

 #define SUICIDE_PIN        54  //PIN that has to be turned on right after start, to keep power flowing."
Using the latest Arduino 1.8.6 and the official firmware posted on the forum.

zonalimitatore
Posts: 78
Joined: Tue Aug 28, 2018 7:12 am
Location: Italy

Re: A10 firmware problem

Post by zonalimitatore » Fri Aug 31, 2018 6:55 am

paultbg wrote:
Thu Aug 30, 2018 10:36 pm
It looks like the "official" firmware for the A10 is broken and will not compile.I get a strange error starting with :

Code: Select all

"In file included from sketch\Marlin.h:21:0,

                 from sketch\Marlin_main.cpp:30:

pins.h:1404:32: error: pasting "/*PIN that has to be turned on right after start, to keep power flowing.*/" and "_DDR" does not give a valid preprocessing token

 #define SUICIDE_PIN        54  //PIN that has to be turned on right after start, to keep power flowing."
Using the latest Arduino 1.8.6 and the official firmware posted on the forum.

Man i have the same issue...
Fortunately, I understand something electronically. except that my logic board was to be thrown away, due to the failure of the bootloader after the flash posted. Now I find myself with a printer that does not read the sd card. Then,I wanted to compile the marlin firmware on its own, but without touching any parameters , if I choose "check and compile" from the menu, here is the string of errors.

What I ask is: "how the hell did he compile it?"
Find the post here: viewtopic.php?f=91&t=61503&start=20
Or im stupid,or here someone like joke

Can I ask you if the sd card of the printer works?

Alex-w
Posts: 148
Joined: Thu Jun 05, 2014 2:24 pm

Re: A10 firmware problem

Post by Alex-w » Fri Aug 31, 2018 11:45 am

:ugeek: Please check the FAQ viewtopic.php?f=96&t=61534
Marlin 1.0.x -- Arduino 1.0.5
Marlin 1.1.8 -- Arduino 1.8.5

User avatar
MichaelK
Posts: 43
Joined: Thu Mar 22, 2018 5:20 pm
Location: Germany

Re: A10 firmware problem

Post by MichaelK » Fri Aug 31, 2018 12:07 pm

you can’t just download something, compile them and believe it works.
The original firmware from here: download/file.php?id=4279 made with an very old version from Marlin and develop with an very old version from the Arduino-IDE. Maybe I think it’s version 1.0.1 or older….

You can’t compile the original Version 1.0.1 with Version 1.8.x

To develop a firmware you need to know about the included type of the mainboard. The A10 use a ATMEGA2560 CPU combined with a RAMPS1.4 + Ultimaker.
Download the firmware: download/file.php?id=4279
Unzip it into a folder named A10_OLD.

Download the actual version of Marlin: http://marlinfw.org/ now.
Unzip it into another folder named A10_NEW

You can open marlin.ino from A10_NEW with Arduino version 1.8.5 or higher now.
And everything has to be adjusted now!
In the configuration.h you need to define the correct mainboard. After that you need to setup the pinout into the right header file.
Are you using Ultimaker you need to setup the pin_Ultimaker.h with the correct pin numbers for the extruder, the endstops so on.
Into the folder A10_OLD you could see the setup from geeetech. You need to know that into the old version you found the pinout into pins.h only.
You can't copy files from A10_OLD to A10_NEW. Sometimes you get many many errors...

After setup the pinout, you need to setup the configuration.h again. Setup the display are you using, Character only, or full graphical or touch screen… Setup Jerks and PID, the dimensions of the printer, the functionality of the Endstops and Extruder continue over the fans.
You can setup more functionality to define autolevel with a sensor or manual level. Activating debugging to use M43 to watch the pinout. M42 to setup manually on and of input or output pins from the 2560 CPU……… and you need know somthing about the G-Code. The speech from mostly 3d printers...

always nice to compare with the A10_OLD folder and....into Arduino-IDE you need to activate all the libraries that Marlin use. Library for the display, the type of CPU and so on.

This is how programming works with a 3d printer.

Download - compile - to believe you did something yourself - :mrgreen: :lol:
Change one value and watch the many errors you get.... :lol:

User avatar
_kaktus_
Site Admin
Posts: 1258
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: A10 firmware problem

Post by _kaktus_ » Fri Aug 31, 2018 12:55 pm

Hi
:mrgreen:

Alex, would it be possible for you to prepare binary files for a few basic configurations?

The current situation is very troublesome for many users, not necessarily newcomers.
;)
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

Alex-w
Posts: 148
Joined: Thu Jun 05, 2014 2:24 pm

Re: A10 firmware problem

Post by Alex-w » Fri Aug 31, 2018 2:22 pm

@kaktus

You mean .hex file? Yes.

I will push new smartto tool which can upgrade machine with .hex file at the same time but not today. :)

User avatar
_kaktus_
Site Admin
Posts: 1258
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: A10 firmware problem

Post by _kaktus_ » Fri Aug 31, 2018 3:33 pm

;)
Yes, I think users don't have to compile the code themselves.
If they could download an already compiled file from the repository, it would be much easier to do so.
:roll:

:idea:
Facing further problems related to this. Files must be well described so that you know which one is related to which printer and its configuration.
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests