MeCreator 2 does not work after replacing Mainboard

Post Reply
JustTotallyMe
Posts: 5
Joined: Sat Apr 27, 2019 11:40 pm

MeCreator 2 does not work after replacing Mainboard

Post by JustTotallyMe » Sun Apr 28, 2019 12:14 am

Hi guys,

I have a serious issue with my MeCreator 2.

Since the part-fan fried my mainboard cause of some malfunction, I had to replace it.
I made sure to replace the board with the exact some board. Therefor I am using a 2560 rev B.

On the board, everything looks the same (so no different connectors or anything like that).

I uploaded Marlin 1.0.4 (the firmware for the MeCreator 2, which can be found in this forum). At first everything seemed to work but as soon as I connect the extruder-stepper to the board (using this long thick cable on the back), the hotend-temp shows 356 and therefore the board goes to MAXTEMP-error.
(what makes it even stranger is the fact, that the heater nor the temp-sensor is connected to the PCB at this point).

I already made sure, that nothing on the PCB is connected wrong.

Another thing which is pretty weird is that if I set the temp of the bed to 60C it goes up to 60 but the bed is not really warm. If I set it to 135C the bed will get warm but not 135C hot.

Can someone in this forum please help me with this?

Did I do something wrong or are the pin-outs somehow wrong on the new board?

Thanks in advance,

JustTotallyMe (a.k.a. Andy)

User avatar
_kaktus_
Site Admin
Posts: 1176
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: MeCreator 2 does not work after replacing Mainboard

Post by _kaktus_ » Sun Apr 28, 2019 1:53 am

Hello.
:mrgreen:

This situation is really embarrassing.

Can you upload photos of the old controller board and the new one :?:
I doubt it is an identical model.
The versions of the controller board do not agree on the order of the cables in the plugs. :roll:
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

JustTotallyMe
Posts: 5
Joined: Sat Apr 27, 2019 11:40 pm

Re: MeCreator 2 does not work after replacing Mainboard

Post by JustTotallyMe » Sun Apr 28, 2019 4:59 pm

Hi,

thanks for the reply.

Here you can see the requested pictures:

This is the old board:
https://ibb.co/wCgFC9H
Image

This is the new board:
https://ibb.co/6rCynBn
Image

The only difference is the connector on the bottom left. On the old board, the connector is facing left and on the new board, it is facing up.
Both are 2560 rev B.

Please tell me, if there is anything else you need to know :)

User avatar
_kaktus_
Site Admin
Posts: 1176
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: MeCreator 2 does not work after replacing Mainboard

Post by _kaktus_ » Sun Apr 28, 2019 5:17 pm

Hi.
:mrgreen:

For common sense, everything should work. :D

But from the presented symptoms I think that the order of the signals in the socket could have been changed. :roll:

So it's worth to check it out.
The sequence of signals is also affected by the file with the configuration of leads for firmware.
;)
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

JustTotallyMe
Posts: 5
Joined: Sat Apr 27, 2019 11:40 pm

Re: MeCreator 2 does not work after replacing Mainboard

Post by JustTotallyMe » Sun Apr 28, 2019 7:13 pm

That does not sound like fun :D

Hm ok so is there a tutorial on how I should proceed?

User avatar
_kaktus_
Site Admin
Posts: 1176
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: MeCreator 2 does not work after replacing Mainboard

Post by _kaktus_ » Mon Apr 29, 2019 12:42 am

Hi.
:mrgreen:

To verify these specifications, you will need a schematic diagram of the controller board.

By looking at the individual connections you can see if everything is okay.

Tell me, how did you compile the firmware, did you specify the appropriate configuration file (I mean pin assignment) :?:
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

JustTotallyMe
Posts: 5
Joined: Sat Apr 27, 2019 11:40 pm

Re: MeCreator 2 does not work after replacing Mainboard

Post by JustTotallyMe » Mon Apr 29, 2019 1:38 pm

Ah ok.

No I uploaded the firmware as is.
I thought the boards are always the same (especially if coming from Geetech) so I did not tinker around with it.

Also another question would be: how can I find a schematic diagram of the board when they change so much?

Like how can I make sure that I have the right schematic diagram for my new board

JustTotallyMe
Posts: 5
Joined: Sat Apr 27, 2019 11:40 pm

Re: MeCreator 2 does not work after replacing Mainboard

Post by JustTotallyMe » Mon Apr 29, 2019 2:09 pm

ah I found the schematics for the rev b. but how do I know what E0M 1A or HE0- means?

User avatar
_kaktus_
Site Admin
Posts: 1176
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: MeCreator 2 does not work after replacing Mainboard

Post by _kaktus_ » Tue Apr 30, 2019 12:04 am

Hi.
:mrgreen:

This is where you have to activate your imagination. :D

I'm guessing HE0 is the extruder heater number 0.
However, E0M 1A, this may be the first lead (1), the first coil (A) of the extruder no. 0 motor .
;)
On the forum I help to use the rod, I don't give fish.
Geeetech Prusa I3 M201 Dual extruder Mixcolor 3D printer, bought 2017-12-19, already built, in the cognitive and improvement phase
Geeetech filament, ABS only
Geeetech 3D WiFi Module for 3D Printer, bought 2018-04-15, He got a new life, and still lies in a drawer.
Positively frenzied customer of Getech Technology.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest