Communication timeout - reset send buffer block

Post Reply
TVarius
Posts: 2
Joined: Mon May 01, 2017 1:41 am

Communication timeout - reset send buffer block

Post by TVarius » Fri Jun 01, 2018 2:15 am

I have had this i3 X printer for over a year now and all of a sudden when I print, itll stop midway and show a communication timeout error in rep host log and says "card removed" on LCD, suggestions? I have already tried reflashing firmware, trying different cables and printing directly from the SD card and when I print from SD card it just stops what its doing and says "card removed"

Code: Select all

18:55:55.102 : Printing layer 66 of 67
18:55:55.102 : N26529 G1 X69.472 Y110.342 E4422.982 F1800*15
18:55:55.103 : N26530 G1 X69.472 Y99.39 E4423.527*101
18:55:55.104 : N26531 G1 X77.053 Y99.39 E4423.904*97
18:55:55.214 : Communication timeout - reset send buffer block
18:55:55.214 : N26532 G1 E4419.904 F1800*57
18:55:55.215 : N26533 G0 X89.894 Y99.39 F9000*120
18:55:55.216 : N26534 G1 E4423.904 F1800*54
18:55:55.320 : Communication timeout - reset send buffer block
18:55:55.320 : N26535 G1 X97.478 Y99.39 E4424.282*100
18:55:55.321 : N26536 G1 X97.478 Y110.345 E4424.827*106
18:55:55.322 : N26537 G1 X89.894 Y99.39 E4425.49*83
18:55:55.427 : Communication timeout - reset send buffer block
18:55:55.428 : N26539 G1 E4421.49 F1800*9
18:55:55.429 : N26540 G0 X97.036 Y125.498 F9000*122
18:55:55.430 : N26541 G1 E4425.49 F1800*2
18:55:55.541 : Communication timeout - reset send buffer block
18:55:55.541 : N26542 G1 X97.478 Y125.317 E4425.514*100
18:55:55.542 : N26543 G1 X97.478 Y137.396 E4426.115*105
18:55:55.543 : N26544 G1 X96.645 Y137.396 E4426.156*100
18:55:55.647 : Communication timeout - reset send buffer block

User avatar
_kaktus_
Site Admin
Posts: 365
Joined: Fri Dec 15, 2017 10:06 pm
Location: PL
Contact:

Re: Communication timeout - reset send buffer block *help*

Post by _kaktus_ » Fri Jun 01, 2018 2:02 pm

Hi
I had a similar case, but the problem was that I tried a different type of connection.
When I restored communication via COM port not all settings were returned as before.

BabyPenguin
Posts: 4
Joined: Mon Jun 04, 2018 9:28 pm

Re: Communication timeout - reset send buffer block *help*

Post by BabyPenguin » Mon Jun 04, 2018 9:30 pm

Currently having the same issue, causes the whole printer to disconnect anywhere from 5 minutes in to an hour in and unable to resume a print. Really confused on what could be causing the problem

BabyPenguin
Posts: 4
Joined: Mon Jun 04, 2018 9:28 pm

Re: Communication timeout - reset send buffer block *help*

Post by BabyPenguin » Mon Jun 04, 2018 9:32 pm

Currently having the same issue, causes the whole printer to disconnect anywhere from 5 minutes in to an hour in and unable to resume a print. Really confused on what could be causing the problem

interstice2718
Posts: 6
Joined: Thu Mar 17, 2016 8:29 am

Re: Communication timeout - reset send buffer block *help*

Post by interstice2718 » Mon Jun 04, 2018 11:02 pm

I get a similar error.

I have a 3-in-1 controller box with the GT2560 control board in it. I've been using the printer (Repetier and Slic3r) )with no problems for over 2 years. All of a sudden, as of 3 days ago, I get the problem: printer just stops in the middle of a print. Sometimes it happens on the 1st or 2nd layer, sometimes 100+layers into the print.

If I'm printing from Repetier Host, I get "Communication timeout - reset send buffer block"

When I go to check on the print, everything is stopped, heaters are off, extruder is stuck to the part.

I've tried printing directly from SD card, and still get the same stoppage. This tells me it it's not a PC, Windows driver, Repetier or Slic3er issue. Looks like the communication timeout originates on the control board itself.

Not sure what to do about it. It's really annoying. Everything has been working flawlessly for 2+years, and I have parts I need to print.

TVarius
Posts: 2
Joined: Mon May 01, 2017 1:41 am

Re: Communication timeout - reset send buffer block *help*

Post by TVarius » Tue Jun 12, 2018 5:56 am

I finally just said screw it and replaced the controller board with a new upgraded board and its still occuring :(

TVarius
Posts: 2
Joined: Mon May 01, 2017 1:41 am

Re: Communication timeout - reset send buffer block *help*

Post by TVarius » Tue Jun 12, 2018 6:59 am

from what I have found, mismatched baud rates can cause this, in case that helps any of you above. I am currently retesting with matched baud rates since I changed my controller board its gone to COM4 instead of COM3 so im not sure if it was mismatched before or not.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest