Z-Axis moving too far

Kensei
Posts: 2
Joined: Wed Aug 09, 2017 9:27 pm

Z-Axis moving too far

Post by Kensei » Wed Aug 09, 2017 9:38 pm

Hello,

I have a problem with my Prusa I3 Aluminum with the updated lead screw.
The Z-Axis always moves too far in relation to the settings. When I try to print, I home the extruder and calibrate the printer head so that a piece of paper just fits between the head and the bed. Then I start the printing process and suddenly the extruder is about 5 mm away from the bed in z-direction. When I check the z-position, it shows 0.2 mm like it should. The other axis are fine and seem to follow the correct path. After the first layer, the head should move upwards again by 0.2 mm, but instead moves another 5 mm upwards.
I tried this with three different models and always have the same problem.
Therefore, I tried to move the head manually over the prepare menu. I set the interval to 0.1 mm and moved upwards. I got the same result. I lifted the head up by 0.2 mm over the menu and the the motor lifted it up by 5 mm.

So it seems like the printer thinks 0.2 mm is 5 mm. What could be wrong? How can I change this?
One more detail: The main board, which originally came with the printer, did not work (other unrelated problem) and now I am using a replacement unit. Unfortunately, I don't know if the original board functioned correctly.

Thank you very much for your help!

User avatar
William
Site Admin
Posts: 5130
Joined: Tue Jun 07, 2016 9:38 am

Re: Z-Axis moving too far

Post by William » Thu Aug 10, 2017 10:21 am

You have better to replace a new board first, there is a way to calibrate the interval between head and hotbed that means you are able to adjust the endstop position to suit the appropriate interval after you autohome.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Kensei
Posts: 2
Joined: Wed Aug 09, 2017 9:27 pm

Re: Z-Axis moving too far

Post by Kensei » Thu Aug 10, 2017 1:19 pm

Thank you for your answer! Could you explain a bit more what you mean by calibrating the interval between head and hotbed?
Do you mean changing the turns/mm setting in the firmware. The setting right now is 2540 turns/mm for every axis.
I read somewhere, that the right setting is around 400, is that correct?

Hodman
Posts: 2
Joined: Thu Aug 17, 2017 11:01 pm

Re: Z-Axis moving too far

Post by Hodman » Thu Aug 17, 2017 11:06 pm

I am having this same issue and have not yet been able to resolve it. Were you able to get it resolved?

User avatar
William
Site Admin
Posts: 5130
Joined: Tue Jun 07, 2016 9:38 am

Re: Z-Axis moving too far

Post by William » Mon Aug 21, 2017 11:28 am

I suggest you upload the firmware of your printer. You can find the firmware for your printer in this web.
http://www.geeetech.com/forum/viewtopic ... 10&t=17046
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Boggy
Posts: 2
Joined: Sun Jun 10, 2018 9:32 pm

Re: Z-Axis moving too far

Post by Boggy » Sat Jun 23, 2018 6:19 pm

I'm also having this problem. I have reflashed the board firmware but no change.

The Z axis is out by a factor of 10. Eg 1 mm of commanded move gives 10mm movement.

Steppers are set at Z=2560
My print starts 3.5 mm away from the bed

Gingko
Site Admin
Posts: 230
Joined: Tue Apr 24, 2018 10:43 am

Re: Z-Axis moving too far

Post by Gingko » Wed Jun 27, 2018 9:17 am

Boggy wrote:
Sat Jun 23, 2018 6:19 pm
I'm also having this problem. I have reflashed the board firmware but no change.

The Z axis is out by a factor of 10. Eg 1 mm of commanded move gives 10mm movement.

Steppers are set at Z=2560
My print starts 3.5 mm away from the bed
If your screw thread is with trapezoidal thread rather than triangle thread, the step/mm should be changed to 400.
Send G Code "M92 Z400" to set up and then "M500" to save it.

geodin
Posts: 1
Joined: Sat Jul 14, 2018 6:02 pm

Re: Z-Axis moving too far

Post by geodin » Sat Jul 14, 2018 6:30 pm

Gingko wrote:
Wed Jun 27, 2018 9:17 am
Boggy wrote:
Sat Jun 23, 2018 6:19 pm
I'm also having this problem. I have reflashed the board firmware but no change.

The Z axis is out by a factor of 10. Eg 1 mm of commanded move gives 10mm movement.

Steppers are set at Z=2560
My print starts 3.5 mm away from the bed
If your screw thread is with trapezoidal thread rather than triangle thread, the step/mm should be changed to 400.
Send G Code "M92 Z400" to set up and then "M500" to save it.
Hi new user with the same problem.
Can you talk me through how to do this step?

If your screw thread is with trapezoidal thread rather than triangle thread, the step/mm should be changed to 400.
Send G Code "M92 Z400" to set up and then "M500" to save it.


Thanks.
geodin

Gingko
Site Admin
Posts: 230
Joined: Tue Apr 24, 2018 10:43 am

Re: Z-Axis moving too far

Post by Gingko » Mon Jul 16, 2018 11:59 am

Hi, Geodin
Firstly, the printer should be connected to slicer software, then in (manual) control box, there is an input box,
you could send GCode through it, first "M92 Z400" then send "M500" to save.

After that you can check through LCD->Control->Stepmm to see if it has been changed successfully.

Fabian Pucciarelli
Posts: 1
Joined: Thu Jan 10, 2019 2:41 am

Re: Z-Axis moving too far

Post by Fabian Pucciarelli » Thu Jan 10, 2019 2:43 am

Same problem FIXED:
Check the threaded rod of your printer(Especially I3 PRO X, I3 PRO W, I3 PRO B, I3 PRO C)
If your printer working with T8 threaded rod
You need to send Gcode"M92 Z400" via USB port.(When you upload the firmware finished)
Then you need to send Gcode"M500" to save the setting.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests