Prusa I3 - Power supply stopped working

Post Reply
DQW
Posts: 33
Joined: Thu Dec 24, 2015 9:23 pm

Prusa I3 - Power supply stopped working

Post by DQW » Tue Dec 13, 2016 2:03 am

Hello,

I have my prusa I3 a while now (from 11/11/2015) and suddenly my power supply stopped working. I gives a slight buzz when I set the power button on. (and the buzz keeps on going very silently.)

Now my guess was it was fried or something similar so I bought the same supply to change it. But when It arrived and I plugged it in. Exactly the same thing happens. So it must be something else.

Any ideas or ways to figure out what's broken?

Kind regards!

User avatar
William
Site Admin
Posts: 6174
Joined: Tue Jun 07, 2016 9:38 am

Re: Prusa I3 - Power supply stopped working

Post by William » Tue Dec 13, 2016 2:15 pm

Hi,
Did your PSU have a overloading?Cuz looks like the old PSU and the new one the the same problem?
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

DQW
Posts: 33
Joined: Thu Dec 24, 2015 9:23 pm

Re: Prusa I3 - Power supply stopped working

Post by DQW » Wed Dec 14, 2016 5:33 pm

Can it be overloaded from the first connection? It instantly did not work.

No green light only the light from the I/O was on. How do I prevent overloading.
And more important how did it suddenly become overloaded? It wasn't overloading before.
Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests