SD Card problem

Post Reply
Timangi
Posts: 2
Joined: Mon Jan 09, 2017 2:08 pm

SD Card problem

Post by Timangi » Mon Jan 09, 2017 2:24 pm

I bought Geeetech Prusa i3 Pro B 3D-printer . Motherboard is GT2560. Printing quality is good and accurate. I have been printing with USB connection to my PC.

So i tried to print from SD-card, but printer did not recognize the card. Printer said that "card inserted", but when i go to menu there is only "no SD card" option and it is empty. I have tried different SD-card with various sizes (128 mb, 512 mb, 1028 mb, 4 gb) and also SDHC and SD cards. I have also tried to format cards in FAT, FAT32, NTFS formats. G-codes has been also in root directory of SD-card.

Do you have answer or solution to my problem?

sladecolin
Posts: 5
Joined: Tue Oct 25, 2016 3:24 am

Re: SD Card problem

Post by sladecolin » Tue Jan 10, 2017 2:48 am

I have the same issue. I have done all the same things to find a solution but no luck yet. My next idea is to check the firmware.

sladecolin
Posts: 5
Joined: Tue Oct 25, 2016 3:24 am

Re: SD Card problem

Post by sladecolin » Wed Jan 11, 2017 3:46 am

Solved!!!

Used a new 32 gb micro sd with adaptor and works like a charm every time.

Found info here:https://www.thingiverse.com/groups/prin ... topic:5759

Use repetier to put files on sd card then put in printer - worked with both power on and power off when I inserted the sd.

Timangi
Posts: 2
Joined: Mon Jan 09, 2017 2:08 pm

Re: SD Card problem

Post by Timangi » Thu Jan 12, 2017 2:14 pm

Problem solved!

I tried to use some high end SD cards which i used in my camera. 32 Gb SDHC with high transfer speed worked perfectly! 8-)

bang
Posts: 402
Joined: Wed Dec 28, 2016 2:12 pm

Re: SD Card problem

Post by bang » Fri Jan 13, 2017 6:07 pm

Bravo :lol:

Myron
Posts: 1
Joined: Sat Jan 07, 2017 4:50 am

Re: SD Card problem

Post by Myron » Tue Jan 31, 2017 8:26 am

sd card did not read

check your lcd and sim cable make shure they have a good connetion
redid my and sd works fine now

wiccan2
Posts: 6
Joined: Mon Jan 16, 2017 2:23 am

Re: SD Card problem

Post by wiccan2 » Fri Feb 17, 2017 3:19 am

I had a similar issue.

Tried a card didn't work.
Put the card from my camera in and it worked.
Put the failed card in my camera and formatted it using the camera and it now also works in the printer. I guess the FAT driver in the firmware isn't very robust and needs the card to be formatted with just the right parameters.

User avatar
jacuse
Posts: 0
Joined: Thu May 03, 2018 7:29 am

Re: SD Card problem

Post by jacuse » Thu May 03, 2018 7:48 am

Hi, everyone. First, sorry for my english, I´m no native speaker.
Second, to the issue:
I own a Geeetech I3 ProB.
I had the same problem: put SD Card, message "Card inserted", but when in the menu, the message: "NO card...".
I formmated a MiniSD Card, with SD adapter, Kingstone 8GB in Windows 10, FAT32, 4KB in allocation size. No change. I tried to name the file auto0.gcode, auto0.g... like I found in other blogs without any luck.
Then I thought that maybe it will be something going on with firmware (arduino on SD reading or so)... But I´m no expert in arduino or marlin programming. So, I give one more chance to formatting, except this time I used a formatting software:
https://www.sdcard.org/downloads/format ... index.html
(for MACs look up for the proper link in https://www.sdcard.org/downloads/formatter_4/)
I performed "Overwrite format" option, or full formatting.
And... It worked!!!
I think Windows makes some funny FAT32 formatting. So go for the source. The software assigns default allocation size for the SD Card, and a clean system volume folder.
Hope this works for others.

TotalNoob
Posts: 1
Joined: Mon Jun 18, 2018 11:44 pm

Re: SD Card problem

Post by TotalNoob » Mon Jun 18, 2018 11:47 pm

Thanks, jacuse!

I have a different printer, (Monoprice Maker Ultimate / Wanhao D6), but I was having the identical issue. The issue began when I updated my firmware. So, I didn't think it was an issue with any physical connections. I originally attempted to resolve the issue by formatting my SD card in Windows, but to no avail.

The software you recommended worked quickly and perfectly. Thank you very much!

Anthony

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest