LCD 2004 Panel Only Showing Blocks

Sherry
Posts: 362
Joined: Wed Jul 01, 2015 12:52 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by Sherry » Mon Jul 13, 2015 9:54 am

Buzz wrote:I haven't got your reply. I have a GT2560 board in a G2S Rostock. To date I am not able to get the printer to respond, getting command waiting in the Repetier Host and the LCD showing 2 lines of block.
regarding to the block on LCD,please reset LCD by press button below the LCD knob.
regarding to the comand waiting,please repluge the hotbed heating wire and extruder wire.could you tell me what LCD show shows,please sent me the LCD picture.

Buzz
Posts: 31
Joined: Thu Jul 09, 2015 7:59 am

Re: LCD 2004 Panel Only Showing Blocks

Post by Buzz » Mon Jul 13, 2015 12:47 pm

The reset button does not work. It still shows 2 lines of blocks. I have already unplugged and re-plug in the hotbed and extruder wires before I post the problem. It is still giving me command waiting. Is the firmware in the GT2560 corrupted that requires reburning?

Sherry
Posts: 362
Joined: Wed Jul 01, 2015 12:52 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by Sherry » Mon Jul 13, 2015 2:39 pm

please try to reburn the firmware.and tell me the result.thx

Buzz
Posts: 31
Joined: Thu Jul 09, 2015 7:59 am

Re: LCD 2004 Panel Only Showing Blocks

Post by Buzz » Mon Jul 13, 2015 6:43 pm

I can't. I compiled with Arduino IDE 1.0.1 on the downloaded RMKA_2560_dual extruder firmware files and I got compilation errors reported on Hitachi LCD. I tried with single extruder firmware files, it gave the same compilation error. I send in a post to the Firmware thread but didn't get answered or published. How do I correct this error? Is something missing from the firmware files.

Sherry
Posts: 362
Joined: Wed Jul 01, 2015 12:52 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by Sherry » Tue Jul 14, 2015 10:19 am

hi,please tell me the following information.
1.did the "compilation errors" display on the LCD or arduino?
2.if "compilation errors" display on the arduino,maybe the com in arduino is not match with the com in device manager.please check the com &board type.
3..did you modify the firmware?maybe the firmware goes wrong.

Buzz
Posts: 31
Joined: Thu Jul 09, 2015 7:59 am

Re: LCD 2004 Panel Only Showing Blocks

Post by Buzz » Tue Jul 14, 2015 1:40 pm

No. Nothing is working yet on my G2S. The LCD is showing 2 lines of blocks. I want to burn the firmware to the GT2560 again because of this. Before uploading, I clicked verify in Arduino. When verifying the firmware files, I should be able to do this without connecting the printer. During verification it gave the errors on the Hitachi LCD and I cannot upload the firmware.

Sherry
Posts: 362
Joined: Wed Jul 01, 2015 12:52 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by Sherry » Tue Jul 14, 2015 2:31 pm

regarding to the firmware burning ,refer to the link:http://www.geeetech.com/wiki/index.php/ ... le_Burning

Abelipokwen
Posts: 2
Joined: Sat Aug 15, 2015 1:19 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by Abelipokwen » Sat Aug 15, 2015 1:56 pm

Hello.. it same problem with me.. some time it working, if unplug in 3-5 hour or more. when switch OFF and ON, it not working again. i thing board problem, like won't start.. but i have order new board..

cpt1nsano
Posts: 5
Joined: Sun Sep 13, 2015 10:55 pm

Re: LCD 2004 Panel Only Showing Blocks

Post by cpt1nsano » Mon Sep 21, 2015 10:17 pm

I too have a wacky display. Was fine until I updated may Sanguinololu with Marlin 1.1. Now printer is fine but display is 'blocked'. I suspect there is a problem in pins.h. Any help? I have the Aluminum Prusa i3 with the 2004 display. Maybe somebody could post the stock factory configuration files? Thanks.

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: LCD 2004 Panel Only Showing Blocks

Post by Mark » Tue Sep 22, 2015 5:10 pm

Hi, for LCD2004, if you get the backlight and two rows of rectangles as the picture shows, it might be the wrong settings of firmware.
For LCD2004 you should delete the “//” from this line of the code“//#define REPRAP_DISCOUNT_SMART_CONTROLLER”; And add “//” in front of the code” #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER”, because this line is for LCD12864. Then upload the firmware.

Before delete the “//”
// The RepRapDiscount Smart Controller (white PCB)
// http://reprap.org/wiki/RepRapDiscount_Smart_Controller
//#define REPRAP_DISCOUNT_SMART_CONTROLLER

// The GADGETS3D G3D LCD/SD Controller (blue PCB)
// http://reprap.org/wiki/RAMPS_1.3/1.4_GA ... with_Panel
//#define G3D_PANEL

After delete the “//”, it should be like this:

// The RepRapDiscount Smart Controller (white PCB)
// http://reprap.org/wiki/RepRapDiscount_Smart_Controller
#define REPRAP_DISCOUNT_SMART_CONTROLLER

// The GADGETS3D G3D LCD/SD Controller (blue PCB)
// http://reprap.org/wiki/RAMPS_1.3/1.4_GA ... with_Panel
//#define G3D_PANEL
Attachments
QQ截图20150922171006.jpg
QQ截图20150922171006.jpg (90.31 KiB) Viewed 10651 times

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests