Printer wont connect. COM Error

Post Reply
Ethan.D
Posts: 2
Joined: Sat May 23, 2015 4:51 pm

Printer wont connect. COM Error

Post by Ethan.D » Sat Aug 29, 2015 8:28 am

Hi There

I have been using my Pro C for a few months without any problems on windows 7. Recently i have updated to windows 10 and now my printer is getting connection errors. It either says COM4 is busy or in use, or "access to COM4 is denied".

Can anyone help with this issue?

Cheers

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Printer wont connect. COM Error

Post by Mark » Mon Aug 31, 2015 6:00 pm

win10...haven't used the system before, suggest you use win7.

flipdave
Posts: 6
Joined: Sun Nov 15, 2015 5:05 am

Re: Printer wont connect. COM Error

Post by flipdave » Tue Nov 17, 2015 4:04 am

I have the same problem with my new Prusa I3 X. I have laptops running Win 7, Win 10, and a MacBook, none of them can connect, either using Arduino for updating the software, or using Reptier host or server. Get the error "access to Com7 is denied". Since it effects all laptos and hosting software, I'm assuming it's the control board that is rejecting the connection!

Please offer a solution, and telling me to update the firmware won't help, because I'm trying to do that now to fix my X drive homing in the wrong direction!

Thanks

Mark
Posts: 1553
Joined: Thu Aug 06, 2015 9:19 am

Re: Printer wont connect. COM Error

Post by Mark » Wed Nov 18, 2015 11:21 am

Did you select the correct baud rate? and how's your COM prot here?
QQ截图20151118112001.jpg
QQ截图20151118112001.jpg (137.53 KiB) Viewed 4651 times
QQ截图20151118111929.jpg
QQ截图20151118111929.jpg (233.52 KiB) Viewed 4651 times

flipdave
Posts: 6
Joined: Sun Nov 15, 2015 5:05 am

Re: Printer wont connect. COM Error

Post by flipdave » Wed Nov 18, 2015 11:56 am

Yes, on the Win 7 and Win 10 laptops I see that same thing posted in the two pictures you sent. When trying to update the firmware, I get the same "access denied to Com port X" after compiling using the Arduino app. I bought a new Win 7 laptop today, and just tried it, and I was able to connect and perform the firmware update successfully! So, I think I'm good now!

Thanks for your help and responses

Dave

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests