Page 1 of 2

Prusa i3 Aluminium unexpected motion problem

Posted: Sun Jan 03, 2016 10:35 pm
by balearic.dynamics
Hello, I am experiencing a very strange problem I found very difficult to identify and debug.
I bought a Geetech Prusa i3 Aluminium, directly from Geetech in China through a Chinese partner I am working with (using the sanguinololu board controller), assembled and used it to prototype projects for about one month. After the first tests I have found the good settings to manage the printer producing very good prototypes I use for work.

A couple of days ago, a strange things happened coming me crazy. Starting a print (a design already printed several times before) I saw the axis moving extremely fast, so the print head does not move at all due the loosing of the steps. First of all I checked all the settings again and all was unchanged, including the firmware setup from the Repieter configuration option. The printer homes the axes correctly, responding with no issues to the manual commands and the heating curves for both bed and print head are correct. Tried again and got the same problem.

I have tried to slide with both Cura slicer and Slic3r with the same result. Then I started debugging the generated g-code. The axis motion feedrate is determined by the G1 code including (when the feedrate should be changed) the feed F parameter.
Values are correct based on the configuration settings; I keep the acceleration almost low (between 200 and 500 in the different conditions) to grant a low average speed change also during long paths.
As far as I know, I set in the configuration parameters the speed in mm/s (millimeters per seconds) while the F parameter in G1 gcode command use the feed rate in mm/min (millimeters per minute). So it sounds normal, and all worked fine until two days ago.

The first lines of a previously working g-code file shows

Code: Select all

M190 S100.000000
M109 S220.000000
;Sliced at: Sun 03-01-2016 11:32:05
;Basic settings: Layer height: 0.2 Walls: 0.8 Fill: 20
;Print time: 1 hour 1 minutes
;Filament used: 5.147m 15.0g
;Filament cost: 0.31
;M190 S100 ;Uncomment to add your own bed temperature line
;M109 S220 ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G1 Z15.0 F6000 ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F6000
;Put printing message on LCD screen
M117 Printing...
where the feed rate is set in values around 6000 that means 100 mm/s for fast moving.
Instead the printer comes crazy.
I have tried to send manually some gcode z-moves from the Repieter manual control interface and this focused the problem: without any change in the settings, by two days the firmware seems interpreting the gcode F parameter as mm/s instead of mm/min generating an unacceptable speed over the axis movements.

I have no idea if this is a software problem and in this case what are the parameters that went wrong or if it is some strange of hardware issue producing this result.

As I am a hardware engineer and developer I have no problem to change parameters on the board source firmware (I have just to install the Arduino platform on the computer I have dedicated to the 3D printing) but remain the very strange fact that this phenomenon has occurred without changing nothing.

Thank you in advance for any suggestion or advice.


Re: Prusa i3 Aluminium unexpected motion problem

Posted: Mon Jan 04, 2016 5:57 pm
by Mark
seems like the subdivision of the stepper drivers are not correct, have you checked the jumper caps on the board?

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Mon Jan 04, 2016 6:43 pm
by balearic.dynamics
Hi Mark!

Thank you for your suggestion. Frankly I have not yet checked. Please can you advice me where I can find the jumper settings? In the Geetech wiki ?

Cheers, Enrico

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Mon Jan 04, 2016 7:22 pm
by balearic.dynamics
Hi Mark,

I have already replied but maybe the text has been lost. I have checked the board (see the attached images) but to be honest, I have not found any kind of jumper on it.
Anyway - also in the case there are jumpers - I am wondering why all what working then things changed ?

in the meantime, as I have powered-on the Aluminium Prusa i3 now I see that also the LCD display has stopped showing me the info page (see the other attached image).

Some idea or suggestion ?

Thanks in advance. Enrico

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Tue Jan 05, 2016 9:56 am
by Mark
Since you didn't kow the jumper caps, so I guess it's ok, actually it is under the driver, remove it and you'll see it.
As there are 2 rows of blocks on the screen then I think you can try to reinstall the firmware, check this link: ... 13&t=17040
and refer to this link to install the firmware : ... 20&t=16433

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Wed Jan 06, 2016 3:22 am
by balearic.dynamics
Hi Mark,

thank you for the suggestions. I have uploaded the firmware after a in-depth check for all the parameters accordingly with the hardware features. Then I have also changed the name of the firmware.
After the upload I have manually powered and set the prusa with repieter: unfortunately all remained the same, nothing changed :(

The printer responds perfectly to the commands excluding the feedrate that seems calculated in mm/s instead of mm/min

Do you think that there is a way I can change the feedrate calculation to workaround this issue? Then the most reasonable thing I think I can do is to buy another sanguinololu board and replace it while in the meantime I can anyway work.

Thank you in advance for your precious support.

Cheers, Enrico

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Wed Jan 06, 2016 3:24 pm
by balearic.dynamics
Hi again, Mark

For your information, a couple of notes. I have checked the firmware sources of the Marlin I have updated (with the right settings for the specific Aluminium Prusa i3) and I saw that in the Marling_main.cpp source the case parser of the Gcode parameters when a gcode feed rate is encountered in a command it is divided by 60 as expected to convert mm/min to the internal calculation of mm/sec.

As the printer behaviour remain the same also after I have burn the firmware again on the snaguinololu board I have done a (crap but understandable) video showing:

- Normal manual moving
- Homing sequence
- Other manual moving (including extruder)
- Execution of some of the Gcode copied and pasted from the slic3r generated file where you see the different behaviour.

The video link on youtube is the following:

Hope this will help. Enrico

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Wed Jan 06, 2016 5:07 pm
by Mark
it's weird, how about use another slice software?

Re: Prusa i3 Aluminium unexpected motion problem

Posted: Wed Jan 06, 2016 5:11 pm
by balearic.dynamics
No matter about the slice software, I have tried with Cura sllicer from inside Repetier and there is no problem at all.

Then also sending manually the specific gcode command, the effect is just focused: the parmeter F=4800 that internally of the marling firmware (marlin_main.cpp) is processed as


has no effect. No idea if it is hardware problem and what kind of hardware problem can be or if it is math problem.


Re: Prusa i3 Aluminium unexpected motion problem

Posted: Wed Jan 06, 2016 5:42 pm
by Mark
since your printer is working well before, I think it might be something wrong with the mainboard cause the LCD is not working too.