compiler errors on unaltered firmware

Post Reply
yeayeahchino
Posts: 7
Joined: Sat Sep 26, 2015 9:50 pm

compiler errors on unaltered firmware

Post by yeayeahchino » Wed Sep 30, 2015 5:03 pm

I can not get the firmware for the GT2560 to compile. At first I thought this may have been because of my modifications. I reloaded the original and am getting a compiler error. temperature.cpp: in function 'void manage_heater().
I am trying to reload the firmware because my x y z axis only move in one direction and dont stop. Maybe I need a more current firmware...

Sherry
Posts: 362
Joined: Wed Jul 01, 2015 12:52 pm

Re: compiler errors on unaltered firmware

Post by Sherry » Thu Oct 01, 2015 9:33 pm

hi,where did you get the firmware for GT2560?
first of all,pelase test the three motors direction.once you start the printer,please test three axis direction by munual control of repetire host.for example,click +10mm in x direction,and clik -10mm as well.in this way,you will know if the motor's direction is correct.if three motors direction are reverased,it will move far away from home when clicking home.finally they will not stop as they do not hit endstops.
if thee axis move toward home but do not stop even if they hit the endstops.in this case,please check if three endstop cables are connected to correct connectors of mainboard.

yeayeahchino
Posts: 7
Joined: Sat Sep 26, 2015 9:50 pm

Re: compiler errors on unaltered firmware

Post by yeayeahchino » Sat Oct 03, 2015 7:33 am

Apologies, I should have done more homework before posting. I was not using the suggested Arduino1.0.1 when compiling the firmware. I have since gotten the motors going in the appropriate directions. Oh to answer your question I downloaded the firmware from this site from a post. Now my remaining configuration debugging is down to the homing and the height of the extruders before the print. I have disabled the software endstops and left the switched endstops on. I have yet to get a decent print but I have gotten A print... But I had to start the print, wait for the extruder to heat up then when the print begins pause it and manually control the bed to retract, center the x axis but then in order to avoid the z axis from readjusting itself back to being too high I manually turn the threads to lower it far enough to reach the heat bed. So correct me if I am off base here but I think from here I need to find the setting for the z axis raising and turn that off...Oh about the homing...is that something in the firmware or do I actually set the home by manually adjusting the position of the bed and extruder and then press the home?

Post Reply

Who is online

Users browsing this forum: No registered users and 30 guests