Delta M301 firmware ( Marlin )

divemasterbill
Posts: 11
Joined: Mon Aug 29, 2016 9:15 am

Delta M301 firmware ( Marlin )

Post by divemasterbill » Tue Sep 13, 2016 12:26 am

Where do I find Marlin firmware for Delta M301?

User avatar
William
Site Admin
Posts: 3721
Joined: Tue Jun 07, 2016 9:38 am

Re: Delta M301 firmware ( Marlin )

Post by William » Tue Sep 13, 2016 9:59 am

-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

divemasterbill
Posts: 11
Joined: Mon Aug 29, 2016 9:15 am

Re: Delta M301 firmware ( Marlin )

Post by divemasterbill » Tue Sep 13, 2016 11:45 pm

This is the link I think is for my machine http://www.geeetech.com/forum/download/file.php?id=2495

It downloads but I can't open it
My Geeetech Me Creator opens to Arduino IDE and I can see Marlin and work with it. This does not open to anything.?

User avatar
William
Site Admin
Posts: 3721
Joined: Tue Jun 07, 2016 9:38 am

Re: Delta M301 firmware ( Marlin )

Post by William » Wed Sep 14, 2016 10:01 am

The way to upload 301's firmware is different from Mecreator,here is the steps you need:
http://www.geeetech.com/forum/viewtopic ... 67&p=32871
And the firmware for 301 is not open source,that is to say,you can only upload it and can modify it.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

divemasterbill
Posts: 11
Joined: Mon Aug 29, 2016 9:15 am

Re: Delta M301 firmware ( Marlin )

Post by divemasterbill » Fri Sep 23, 2016 12:02 pm

Hello, Where can I find explanations on what the " Delta " settings on my 301 do and how to set them . I am having a bad time trying to calibrate . The 1st layer is either too thin or too high to stick , it is very uneven from center to edges. It is also inconsistent , I get 1 decent print then the next day it is all out of order again. Please advise.

User avatar
William
Site Admin
Posts: 3721
Joined: Tue Jun 07, 2016 9:38 am

Re: Delta M301 firmware ( Marlin )

Post by William » Fri Sep 23, 2016 5:23 pm

divemasterbill wrote:Hello, Where can I find explanations on what the " Delta " settings on my 301 do and how to set them . I am having a bad time trying to calibrate . The 1st layer is either too thin or too high to stick , it is very uneven from center to edges. It is also inconsistent , I get 1 decent print then the next day it is all out of order again. Please advise.
Hi,see the picture:
QQ截图20160923172125.jpg
QQ截图20160923172125.jpg (19.9 KiB) Viewed 6852 times
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

divemasterbill
Posts: 11
Joined: Mon Aug 29, 2016 9:15 am

Re: Delta M301 firmware ( Marlin )

Post by divemasterbill » Mon Sep 26, 2016 2:24 am

Where do I find definition / purpose of all the "Delta" settings ex; diagonal rods , smooth offset , effector offset, carriage offset, Delta radius,

User avatar
William
Site Admin
Posts: 3721
Joined: Tue Jun 07, 2016 9:38 am

Re: Delta M301 firmware ( Marlin )

Post by William » Mon Sep 26, 2016 6:28 pm

divemasterbill wrote:Where do I find definition / purpose of all the "Delta" settings ex; diagonal rods , smooth offset , effector offset, carriage offset, Delta radius,
Here is the relevant settings in G2s's firmware,you can refer to it:
QQ截图20160926094846.jpg
QQ截图20160926094846.jpg (40.79 KiB) Viewed 6826 times
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

divemasterbill
Posts: 11
Joined: Mon Aug 29, 2016 9:15 am

Re: Delta M301 firmware ( Marlin )

Post by divemasterbill » Fri Sep 30, 2016 2:32 am

Thanks William for your responses , I can not get this M301 to print with the 3 color hotend! I have tried 2 degree increments from 200 C to 260 C I bought a complete 2nd extruder right from Geeetech I have tried stepper currents from .5v to 1.1v measured on the poteniometer to ground . I bought Geetech aluminum extruder sets (3) . I have tried min to max tension settings . I can not get filament extrude with enough volume . ie. it just barely comes out of nozzle . I changed complete extruder assembly , same problem . I have tried 6 different rolls of filament . I made an adapter mount and put an E3D extruder on and it prints fine . I go back to 3 color extruder and I can not push filament thru fast enough . It either jumps the tension arm or stalls the steppers depending upon tension and current settings. If I take out bowden tubes I can push filament thru with the plunger tool supplied with M 301 without too much force . I don't know what else to try . Please advise I use ABS filaments only . Thank you Bill D.

Toy
Site Admin
Posts: 116
Joined: Mon May 16, 2016 8:40 am

Re: Delta M301 firmware ( Marlin )

Post by Toy » Fri Sep 30, 2016 9:23 am

Make sure the bowden tube have been plugged into the tube deepely enough.
There's a possibility that the temperature is too high and the filament melt in the PTFE tube or the tube is expanded and then prevent the filament coming out
to the nozzle.

You can also disassemble the hotend and see if there's anything wrong or if it's clogged somewhere.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest