Extrusion stepper way off

Post Reply
Veenoh
Posts: 54
Joined: Thu Dec 08, 2016 12:31 am

Extrusion stepper way off

Post by Veenoh » Sun Jan 15, 2017 5:09 pm

I just converted my M301 into a G2s Pro by obtaining the dual hot end, probe, cables and GT2560 controller but otherwise kept the parts from my M301, including the extruders and steppers. Everything seems to be functioning as it should except for the length of filament being extruded or retracted. With nominal estep settings, get less that 50% of the length requested and have to raise my esteps/mm from 93 up to 250 to get it to extrude the right length. Both extruders have the same issue and the estep calculation did work but the resulting number seems way too high.

Furthermore, even with the high estep/mm value, the print starts ok and then the extrusion reduces way down. I don't hear any signs that the stepper is having trouble pushing the filament as I did on my M301. It just seems like it's asking for too little filament to be extruded. This could be a separate issue though.

As far as I know, the M301 and G2s Pro both use the same type of stepper motor. At least the 1.8 deg per step spec is the same.

I adjusted the driver voltage up to 1V but that did not help. I also verified that the jumpers are all in place on the controller board, meaning that 1/16 step resolution should be in place as usual.

Any ideas what might be wrong? Thanks.

--Dave

Veenoh
Posts: 54
Joined: Thu Dec 08, 2016 12:31 am

Re: Extrusion stepper way off

Post by Veenoh » Mon Jan 16, 2017 3:45 pm

I have been having some success working around the problems I reported with my converted G2s. I raised the esteps/mm from the nominal 93 to 250 to get the right extrusion length. I upped the extrusion multiplier to 1.3. And I raised the temperature to 215 and 265 for PLA and ABS respectively. On the last point, I think the thermistors are too high on the temperatures being reported since I checked it with a digital thermometer.

Veenoh
Posts: 54
Joined: Thu Dec 08, 2016 12:31 am

Re: Extrusion stepper way off

Post by Veenoh » Tue Jan 17, 2017 3:41 pm

Success!! It turns out the firmware recommended by Geeetech just does not work with the G2s Pro. I downloaded the Marlin 1.10RC3 branch for the printer and configured it the same way and it works great! The extruder esteps are right on the money at the nominal setting and the temperature is much better. I still have plenty of fine tuning to do but I now have a functioning printer.

I'll post in the firmware section about the bad version.

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests