Arduino Due & Geeetech Iduino Yun Shield: problem starting bridge

Post Reply
hrd
Posts: 0
Joined: Thu Sep 28, 2017 3:51 am

Arduino Due & Geeetech Iduino Yun Shield: problem starting bridge

Post by hrd » Tue Oct 03, 2017 5:32 pm

Hello,

I successfully used your Iduino Yun Shield with an Arduino Mega2560. Now I'm going to use it with a Arduino Due (of course jumper changed to 3.3V on shield) and trying to start the bridge which hangs forever (no "done" as used in following code is coming in monitor only "Starting bridge..."):

[code]
#include <Bridge.h>

void setup() {
SerialUSB.begin(9600);
while (!SerialUSB);
SerialUSB.print("Starting bridge...");
Bridge.begin();
SerialUSB.println("done!");
}

void loop() {
// put your main code here, to run repeatedly:

}
[/code]

I'm not sure what to configure in Luci under Sensors as Arduino Board Type because there is no listing with Arduino Due. Using "Arduino Bridge" as Operation Mode there.

Thanks & Regards
hrd

User avatar
William
Site Admin
Posts: 4327
Joined: Tue Jun 07, 2016 9:38 am

Re: Arduino Due & Geeetech Iduino Yun Shield: problem starting bridge

Post by William » Thu Oct 05, 2017 11:17 am

Maybe you should include the boards.h?
I think you'd better learn the firmware of Arduino IDE examples.
And You can refer to the Arduino Yun shield. It is same with the Iduino Yun.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests