Z AXIS BLOCKED in one direction

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Thu Oct 06, 2016 3:50 pm

Hello! I finished to build my Geeetech Prusa I3 B Acrylic and started the main configuration of the printer. All components works fine except the Z Axis that move in only one direction. I will try to explain better the problem... :|

Using Repetier when I try to set home position all axis bumps endstops and stops, this is not the same for the Z axis, that hit the endstop and push it for other 8-9mm. Also If I try to move the Z axis UP it cointinues to move DOWN, this happen after and before the home position calibration.

I checked several things: Motor Driver (0,8), ENDSTOP Plug and connection (It works fine, in fact when the extruder support bump the endstop I can see the codec of ENDSTOP OPEN/TRIGGERED on the software). I tried also to invert motor sense of turn, and they go, at the same way, UP without the possibility do go DOWN. :oops:

I can't understand what are other possible causes of this problem... I don't know If it's the software... I tried Repetier 1.6.0 and 1.6.2 and nothing changed. Help me please!

User avatar
William
Site Admin
Posts: 4467
Joined: Tue Jun 07, 2016 9:38 am

Re: Z AXIS BLOCKED in one direction

Post by William » Fri Oct 07, 2016 6:03 pm

Hi,
Read your post carefully,i think it's still more likely the connection of Z axis endstop has a problem:
1.You should double check on the two ends of Z endstop wiring(to the board and to the endstop itself),make sure the two ends all have a good connection.
2.If &1 still doesn't fix it,you can swap the connector with other endstops to check if the Z endstop is broken or the Z-min slot on the board is not working.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Re: Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Fri Oct 07, 2016 6:58 pm

Thank you for reply... I think that end stop work well bacause Repetier could show me if it is closed or open... It's like the inversion of motor rotation doesn't exist. What about windows 7 drivers?

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Re: Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Fri Oct 07, 2016 9:06 pm

Thank you for the reply... I think that isn't the endstop the problem, that because on repetier appear when Z endstop is triggered or open and that could means that it is working. What do you think about win7 driver? Could be this the problem?

User avatar
William
Site Admin
Posts: 4467
Joined: Tue Jun 07, 2016 9:38 am

Re: Z AXIS BLOCKED in one direction

Post by William » Sat Oct 08, 2016 9:10 am

The Win7 driver?What exactly do you mean?The driver is just for detecting by computer.
Sounds wierd,you said Repetier shows triggered when Z axis touched it?Generally Z axis moves in one direction i encountered is caused by the endstop.Could you attach a video about the "trigered"?
Anyway,maybe you can have a try on the solutions i proposed.
If it doesn't fix it indeed,you can reflash the firmware to have a try.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Re: Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Sat Oct 08, 2016 11:27 pm

https://www.youtube.com/watch?v=Iji5Pp1OiFU In this video I try to explain better my problem...

Toy
Site Admin
Posts: 116
Joined: Mon May 16, 2016 8:40 am

Re: Z AXIS BLOCKED in one direction

Post by Toy » Sun Oct 09, 2016 11:00 am

First you need to make sure z axis is installed well, the rods can move smoothly when you move it by hand.
You can release the motors from z axis, then activate the motor in repetier, see how it rotates,
you can check if it's the problem of motor, the driver or the motor wire according to the link:
http://www.geeetech.com/forum/viewtopic ... 17&t=17038

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Re: Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Sun Oct 09, 2016 3:55 pm

All wires are right, and motors are well because they run, but only in one direction. The electronic part is right, I tried to change some parameters on the firmware and it seems like there is a block with the rising movement of z Axis.

User avatar
William
Site Admin
Posts: 4467
Joined: Tue Jun 07, 2016 9:38 am

Re: Z AXIS BLOCKED in one direction

Post by William » Mon Oct 10, 2016 2:12 pm

Pierfrancesco wrote:All wires are right, and motors are well because they run, but only in one direction. The electronic part is right, I tried to change some parameters on the firmware and it seems like there is a block with the rising movement of z Axis.
1.Have you tried removing the rods from Z motors and see how it goes?
2.You can swap the driver for Z axis to see if there is a difference.
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

Pierfrancesco
Posts: 13
Joined: Thu Oct 06, 2016 3:37 pm

Re: Z AXIS BLOCKED in one direction

Post by Pierfrancesco » Mon Oct 10, 2016 3:08 pm

If I remove the rods, motors run at the same way in one direction. With another driver nothing happen... It's the same thing :cry:

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests