Won't auto-home at Z axis

Moderator: vert

Mortega
Posts: 4
Joined: Sat Mar 21, 2020 6:04 am

Re: Won't auto-home at Z axis

Post by Mortega » Sun Apr 12, 2020 11:15 pm

Alright, thanks to the Easter holidays I was able to find the error and fix it. So the solution is:

1. Open up your printer and change the Z-endstop cables to the one unused. This means change the cable, initially on the red circle (see below) to the yellow one.

Image

2. Download the Marlin firmware. I got the latest version (v2.0.5.3) and it is working fine, no issues whatsoever of having to reset when uploading. I use Arduino IDE to upload the Marlin.ino file. Make sure that in the "configuration.h" file, you are using the GT2560 V3 board. Eventhough we have the GT2560 V4, it seems the pins are connected to the same ATMEGA2560 ports on both.

#ifndef MOTHERBOARD
#define MOTHERBOARD BOARD_GT2560_V3
#endif

3. Now it seems that the logic pin for this extra switch is connected to the physical pin 9/PE7/INT7 in the ATMEGA2560. See image below. This is confirmed since I proved it with the multimeter.

Image

The easiest is to change the file found in "...\Marlin\src\HAL\AVR\fastio\fastio_1280.h" to change the faulty pin for the unused one, which is not even included in the "fastio_1280.h" file. You can see it is unused on the above image. So, to put it simply, change these original lines of code in the file "fastio_1280.h":

#define DIO30_PIN PINC7
#define DIO30_RPORT PINC
#define DIO30_WPORT PORTC
#define DIO30_DDR DDRC
#define DIO30_PWM nullptr

For these ones:
#define DIO30_PIN PINE7
#define DIO30_RPORT PINE
#define DIO30_WPORT PORTE
#define DIO30_DDR DDRE
#define DIO30_PWM nullptr

And then just upload your firmware and you are all set. This worked for me.
Good luck !

eddyuk
Posts: 44
Joined: Sun Oct 30, 2016 2:05 am

Re: Won't auto-home at Z axis

Post by eddyuk » Wed May 27, 2020 2:13 pm

Thanks all. It took long, but finally I received new mother board this week for the printer and changing it solved the problem. Still don't understand why only autohome was affected but I am happy it works.

User avatar
William
Site Admin
Posts: 6320
Joined: Tue Jun 07, 2016 9:38 am

Re: Won't auto-home at Z axis

Post by William » Thu May 28, 2020 9:27 am

:D
-Keep your mind and try to test it. :)
-Everything will be fun!-Support all Getech printer.
-You can ask me the questions and I will kindly reply.
-Respect others is the best way you can get help!

gopher
Posts: 41
Joined: Tue May 05, 2020 9:41 pm

Re: Won't auto-home at Z axis

Post by gopher » Tue Jun 23, 2020 8:24 pm

@Mortega thanks a lot!
Admins of this forum don't give any information about gt v4 source code :lol: :lol: :lol: :lol: :lol:
That's great the source code for v3 fits for v4.
Very simple move to give source code is impossible for geeetech administration and programmers :lol:

ni3dprint
Posts: 1
Joined: Tue Jul 21, 2020 8:21 pm

Re: Won't auto-home at Z axis

Post by ni3dprint » Tue Jul 21, 2020 8:30 pm

Hello all,

thank you for your help with this v4 board!

I have recently discovered I have the same board and it is very confusing.

A couple of issues you may be able to advise on -

Firmware - I have tried unsuccessfully to compile any Marlin 2.x firmware for this board. The only success I have had is an A10 1.1.8 firmware
Would you perhaps be able to share or provide a link to your Marlin files? What I notice is with all the Marlin 2.x versions in Arduino there are only around 4 files shown rather than the usual hundreds..?

Regarding the firmware the reason I am trying to change it is to add a Chimera hotend rather than the stock A10M mixing one. Strangely enough the extension board on this version of the machine appears to have all the connections required for a dual extruder setup. However as far as I can ascertain the screw in terminals are all all interconnected - its more of a bus connector than separate sets of connections. Am I correct in this? In which case the only way to add dual extrusion is to feed everything back to the main board?

Any help you can offer would be appreciated.

Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests