Search found 4 matches

by dga78
Fri May 03, 2019 2:33 pm
Forum: Geeetech I3 Pro W
Topic: Z axis torq problem.
Replies: 5
Views: 762

Re: Z axis torq problem.

Hi, when I test the travel on the z axis, the motors hums (with gantry removed) but they hardly turn. Its as if they don't have enough voltage, however when I hit the limit with they turn the opposite direction fine. Do I need to up the voltage to the motors (which circuit board is it)? or is there ...
by dga78
Fri May 03, 2019 11:50 am
Forum: LCD Panel
Topic: Display problems of LCD2004/12864
Replies: 16
Views: 45811

Re: Display problems of LCD2004/12864

William, Im having the same LCD issue.
I have flashed the firmware with the above config and still getting the rectangles on the screen.

i3 pro x with 2004.

please help
by dga78
Thu May 02, 2019 11:59 pm
Forum: Firmware
Topic: How to install the firmware for GT2560
Replies: 143
Views: 275796

Re: How to install the firmware for GT2560

Hi guys
Some help please.

Just built a pro x and uploaded firmware (arduino 1.0.1 with Marlin) on my MAC. Firmware loaded and I can connect via USB with Repetier, but the LCD has both lines blocked out. Any ideas?
by dga78
Thu May 02, 2019 11:54 pm
Forum: Firmware
Topic: Firmware for geeetech 3D printers
Replies: 390
Views: 631599

Re: Firmware for geeetech 3D printers

Hi guys, some help please. Just got an i3 pro x, followed all the firmware instructions (adriuno 1.0.1, Marlin). All loaded and can connect with repetier through USB but the LCD screen has the two blocked lines. Ive looked at the refresh button and its clear, the code "//" in the flash was correct a...